Gsender 1.0.0 - Carbide Create/Post-Processor : Unsupported or Invalid GCode Command

I Recently saw a thread recommending to use the Carbide Create “ShapeOko” PostProcessor compared to “GRBL” PostProcessor.

So, for my next project i decided to test that out, even if this job did not require a Tool Change or Pause.
Note: I do have the Limit Switches on my Longmill 30x12

2 seconds after start i get this message.


I had to go back to the" GRBL" PostProcessor and it all worked…

Any comments? Explanations? Thanks…

CC “GRBL” PostProcessed File:
new-workbench-both-pocket– (302.3 KB)
CC ShapeOko PostProcessed File:
workbench-both-pocket– (302.6 KB)

@webbit_NJ , I won’t download your files because the visible link and the actual link are different, and the actual link is a shortened version of the link and obscures the actual location linked to.

I don’t know why that is that way.

1 Like

I tried the files and don’t get any errors.
I tried both files and the both run all the way through.

I think it’s just the way the forum names/shortens files.

Thanks, i will retest in my next session…

@webbit_NJ - The program is stopping on the first M6 command which is at the front of the file most likely. You only need to hit resume to continue running. Or you can go into settings and select tool change. Then you can set it to Pause, Ignore or add code that you may want to run when it finds the M6. Easy peasy.

Indeed… The Settings for ToolChange was “Code”, and the GCode in both fields were a remnant of some bad experimentation.

I cleared the “Bad ToolChange” GCode and all is good.

My Fault, but it would have been nice if GSender would have specified that the Gcode Error was not on the JOB GCode file, but the “ToolChange Code”.

I will experiment the CC “ShapeOko” PostProcessed feature again on next project…


I can get something similar to happen, without any bad gcode. I think it’s a gSender bug. Here’s the setup.

  1. Create gcode with M06 (tool change commands) in it.
  2. Set gSender to handle tool changes via code.
  3. Put a pause command “M0” anywhere in the second code block in gSender.
  4. Run. I get the error as below.

If I use pause for how to handle tool changes in gSender there is no error. If I do not put a pause command in the second block, there are no errors. Even if the only command in the second code block is a pause command the error occurs.

Does anyone else see this?

Can you share the gcode file you created?

I should be able to test tonight…

Here’s the gcode I was using. (26.1 KB)

I was not able able to reproduce!!!
I tested an thought i did reproduce, but then i figured out i had typed “MO=O the letter” (not M0 = MZero)
Sorry… :frowning:

These types of inconsistent issues could be caused by communication issues or problems with the way commands are intercepted/buffered.
@SLabuta What happens if you put a G4P0.1 on the line before and after the M0? (Sorry, no time to test now)

OK, this is just getting weirder… If I add the G4P0.1 command to wait for a tenth of a second after the M0 pause command, I do not get any errors. BUT, it skips one corner of the square that is getting cut in the gcode right after the tool change. See the gcode I attached earlier. Just the initial corner is missed. Like a part of the gcode got skipped over. I tried increasing the wait command up to a second and it was still occurring. Still, no issues are seen if the M0 command is not included at all in the last code block.

I will have to test tomorrow.
I once had a skip problem when I paused manually in a job (don’t remember if it was via GSender or push button on longboard) it “forgot” to go up (skipping a z move) and the endmill passed through the material. Nothing broke, but I was surprised.

Sounds like the Pre and Post “Hooks” might not be ready for prime time.
@SLabuta, you have a BitSetter? The macros work without issue. Leave the code blocks blank and just run macros.

Any confirmation if this is still happening as of 1.0.2? I am unable to recreate it with M0 in either pre- or post- hooks. We made some changes in 1.0.1 to address it.


Yes, it still happens for me.

This is the gcode file (From Carbide Create) (26.1 KB)

Here’s the errors:

Here are the settings for tool changes:

If I just remove the “M0” command the errors go away.