gSender 1.1.0 freezes at the splash screen

I have gSender 1.1.0 installed on two pcs. Both are running windows 10 64 bit 21H2.

On both, every time I start gS, it freezes on the splash screen. I have to close it in task manager. On opening it a second time, it opens every time. I did not have this issue on previous versions. They were all quite slow to load, but they all eventually did open.

Before installing 1.1.0, I uninstalled 1.0.6, as I always do. I never had 1.0.7 installed.

Grant

I had the same issue on my Intel(R) Atom™ x5-Z8350 CPU @ 1.44GHz 1.44 GHz running Windows 10 Pro 64 bit 21H2 out in the shop. My wintel only has 4 gig of memory which gets used up pretty quickly with updates.

I ran a disk cleanup on my c:/ drive …using the advanced option.

gSender 1.1.0 ran correctly after that.

Andy

@Andy1 Tks, Andy. I’ll take a look at that. Strange that the problem arises on two different PCs. I have 8Gb of ram in one and 16 in the other. So, I don’t believe ram is the issue. I’m running an SSD as the primary drive in both, too. So, loading speed is not an issue.

Worse case, I can go back to 1.0.6, which ran perfectly.

That’s what I’m doing at 1.0.4. Waiting for a version that works out-of-the-box. Oh wait; there is no box! :smiley:

I’m thinking there isn’t enough significant testing of each version with all of us beta testers standing by! :wink:

Interesting tidbit guys. I installed 1.1.0 yesterday on my CNC computer. A 4gb Lenovo with 250gb SSD. Win 10 64 bit 21H2 as well. Was playing around with my first attempt at an inlay. The female pocket went without a hitch. A 28 minute run. Then when I started the male inlay is when the fun started. It was an hour run and was 47% into it when the screen froze but the gcode kept on running. It looked like it was working so I let it run. I kept seeing a window flash by on the screen but it was so quick I couldn’t see what it was. I used my iphone to record a video so attempting to download to my design computer so I can freeze frame to see what it says. Anyway after about 15 minutes the screen all of a sudden unfroze. It picked up at 67% and ran to completion. Male inlay wasn’t perfect but looked like it was supposed to. I’ll update this post when I can get the video loaded and get a snapshot of the message.

1 Like

Grant:

To be complete, I downloaded gSender in the house which runs Windows Pro 10 64 bit 21H1 with 16gigs on an Intel(R) Core™ i7-3770K CPU @ 3.50GHz 3.50 GHz

gSender 1.1.0 works fine there as well.

Curious, but now I see Heyward running a similar setup with what looks like a memory problem, don’t know not a computer guy so i’ll wait and see.

Andy

Ran a three hour bowl job yesterday with 1.1.0 with no issues on Win 10 pro. Hard wired to the network, not wifi. Did you run the file from a local drive or a network drive? I always copy the files to a local drive so it is not network dependent.

@gwilki @andy @chrismakesstuff - Ok. As to my problem with the screen freezing then continuing after it stopped. I finally was able to capture the error message that was flashing on my gS screen that was way to fast to see. Fortunately it flashed every minute or two. It says (with a big red X) that the “Server Connection was Lost”. And with a button to try and reestablish the connection. Unfortunately it doesn’t stay on the screen so you can click the button. I’m sure this is something the Sienci team needs to see. I am attaching a picture of the message. Again I was 47% into an hour long job. As above the screen started back up on its on at 67% and ran to completion.

2 Likes

I have had the same freezing on opening issue as well with the new version.

Hey folks,

We’ll be looking into this ASAP. It’s something that didn’t happen across the 10+ machines we’ve been testing on, but might be something related to a specific setup/configuration.

If you can share your current settings file (‘C:\users{Your user name}\AppData\Roaming\gSender\gSender-0.5.6.json’) that would help narrow down if it’s an issue specific to something you’ve configured.

While there, if you can take a peek in logs/main.log and see if anything shows up as an error.

Thanks, we’ll look into why this is happening for some users as quickly as possible.

@KGN Here are mine, Kevin.

PC1

gsender-0.5.6.json (34.5 KB)

main.log.txt (8.6 KB)

I can’t get to PC 2 today. I tried it first thing this morning, and gS would not open at all - not even to the splash screen. I tried a few times from the start menu icon and the desktop icon. Task manager showed 4 instances of gS running. I could not stop any of them on task manager. I had to re-start the pc to get rid of them.

1 Like

Hey folks,

If you’re experiencing freezing on splashscreen and have time to, would you be able to download the following test build and let me know if it fixes the issue for you (64 bit specific)? We’d love to be able to test this in house but can’t recreate it on any computers here.

Removed dev build since it’s live as an actual release

Make sure any gSender processes are closed before running and try opening/closing a few times. If it seems to have solved the issue, we’ll push an actual build out to everyone.

@Fancu12 @gwilki @Andy1
Kevin

@KGN - Kevin - Here’s my settings and log. The log will probably not show anything since I ran a surfacing run after the issue. Hopefully the settings will provide whatever you are looking for.

gsender-0.5.6.json (31.3 KB)

main.log.txt (4.0 KB)

@KGN I tried to download that file in Firefox and nothing. In Edge, I get this message

uncommon

It still seems to download and save, but it saves as Unconfirmed 126583.crdownload for the file name.

I’ll try it later today and report back.

Kevin:

I downloaded gSender in the house which runs Windows Pro 10 64 bit 21H1 with 16gigs on an Intel(R) Core™ i7-3770K CPU @ 3.50GHz 3.50 GHz

gSender 1.1.1 works fine.

On my Intel(R) Atom™ x5-Z8350 CPU @ 1.44GHz 1.44 GHz, 4gigs mem, running Windows 10 Pro 64 bit 21H2 out in the shop.

Failed on first attempt, got to the splash screen, waited five minute at least

I ran a disk cleanup on my c:/ drive …using the advanced option.

gSender 1.1.1 ran correctly.

gsender-0.5.6.json (29.4 KB)

Kevin

Focusing on my 4gig Wintel in the shop, i have now installed and re installed various past versions including version 1.1.1

It turns out that I just was not waiting long enough for my little box by the looks of things, my bad habit of inadvertantly double clicking the desktop gsender icon is not helping matters. I now right mouse click it and choose “Open” which avoids having multiple instances of gSender running. I am not sure how many processes are supposed to be running but my task manager shows (5)

At any rate, the current version 1.1.1 is definitely faster than 1.1 for one reason or the another (electron??). It takes 20 seconds to display the splash screen and about 5 seconds or so to display the program.

Thanks for your time and effort

Andy

I was seeing the same issue on 1.1.0. On the initial load of gSender the first splash screen would come up and then nothing else would happen. gSender’s CPU utilization would go to zero and it would hang. I would kill it via Task Manager and then it would run all subsequent times just fine. Here’s the json file from 1.1.0 .
gsender-0.5.6 - Copy.json (31.4 KB)

I have installed 1.1.1 and it has not hung up once (out of two reboots…) Here’s the latest json file.
gsender-0.5.6.json (31.4 KB)

So far, so good.
I’m on Win 11 Pro (21H2) using a low-power Celeron J4125 CPU.

Thanks folks, we’ve started an actual build with the above changes and a few others, which hopefully should be out later today/early tomorrow.

1 Like

@KGN Sorry to be late the party, Kevin. I can open 1.1.1 on both PCs. Thanks much for the sudden service.

1 Like

Hi Kevin, I have the same problem, get stuck on splash screen with 1.1.1 running Pi400, killed all gSender process, rebooted, and tried multiple times, was fine with the previous version?