gSender 1.2 problems with bluetooth Xbox controller

I have been using an Xbox blue tooth controller with Version 1.1.7 and its been fine. All buttons worked as programmed.
Installed Version 1.2 now only the joystick works - sometimes - then stops working. Tried reprograming the buttons and none will work.
Close the program and reload and the joystick may or may not work. If it works its only a couple of times then stops.
Tried to uninstall and re-install version 1.1.7 but it will not run - just hangs when loading.
How can I reinstall version 1.1.7?

1 Like

Just an update. I can install and run gSender 1.1.7 on my computer if I install it under another user account on my computer.
It WILL NOT run if I install it under my account in Windows 10.
I can run it from my account if I right click in the file and run it using the other user credentials…
Any help?

@Lappa when you uninstall there is a hidden file left behind. You have to go back to the program folder right click select show hidden files and folders and manualy delete the files. You can then get a clean install of 1.1.7.Hope this helps

GSender installs in 3 areas:
A) Users/“me”/ .sienci-sessions directory.
B) program files/gSender directory
C) Users\“me”\AppData\Roaming\gSender. Amended thanks to Michael
D) Users\“me”\AppData\local\gSenderUpdater - found this one later as well

When you uninstall, it gets rid of all of B) including the directory - no hidden files left but leaves A) and C) and D) behind. When I delete all of these and no hidden files left, it still hangs.

Which of the above contains the hidden file or is it elsewhere?

Didn’t see Users\“me”\AppData\Roaming\gSender in your list. There are files there as well.

1 Like

I removed user:\micks\appdate etc but while it worked yesterday when I tried it again today 1.17 hung up on the opening screen. Looked everywhere for hidden files in windows I eventually did a factory restore then loaded 1.2 and it works flawlessly.

Sorry. Wrong info from me.
C) should have read Users\“me”\AppData\Roaming\gSender. I’ve amended that post
There is also a D) Users\“me”\AppData\local\gSenderUpdater which I’ve added to the above post.
Still no joy - hangs on opening screen - version 1.1.7.
I’ll have another look around today but I can get it to work by opening it under another user account on my computer. Inconvenient but at least I can use it.
I installed it under my account so this hidden file ? doesn’t seem to be the problem - it just won’t run under my Win 10 account “me” but will run under another account “CNC” on the same computer.
I use the “runas. Exe” command in a shortcut on my desktop.

Version 1.2 loads and works but it has major problems with my Bluetooth Xbox controller.
Version 1.1.7 works flawlessly with the Bluetooth controller which is the reason ( as explained in my first post) why I want version 1.1.7 back until they fix the bug in version 1.2.

A question for the people who wrote the program.
Why does the gSender Uninstall routine leave all these directories untouched?

I noticed that a fix to allow you to revert from version 1.2 back to version 1.1.7 was posted 18 hrs ago.
link here

So that allows me to use the XBox controller again by reverting to V1.1.7.
Hope they fix Version 1.2 so I can use he XBox controller in that version.

I have seemingly got a fix for this issue now, if someone could send me their settings file by exporting it in gsender 1.2.0 I can use it to validate the fix.


Walid K.