gSender 1.3.8 Edge ignores spindle delay

Just updated to Edge 1.3.8 and testing I’ve noticed the job starts moving before the spindle gets up to speed. I tried turning off/on the delay setting and there is no change. (1.2.2 works as expected)

Now switching back to 1.2.2 and it’s not responding to the delay option.

@hamanjam You may want to write to tech support.

When you say that you “switched back” to 1.2.2 from Edge, did you actually uninstall 1.2.2 when you installed Edge. They can both be on the PC at the same time. That’s why I ask.

Here is a link on how to revert to previous versions of gSender. I thought that it only applied to situations where someone updated gSender from say 1.1.7 to 1.2.2, ,and wanted to go back to 1.1.7. No Edge installation involved. However in a pinch, you could try it.

I have not tried this and can’t guarantee the results, though.

Sorry, I could have been more clear. I have both 1.2.2 and 1.3.8Edge installed. I just closed Edge and opened in 1.2.2.

I would prefer not to have to roll back to 1.1.7 unless necessary for specific troubleshooting. I will try rebooting to see if there was something cached between Edge and 1.2.2. It just seemed odd because the delay was working in 1.2.2 until I tested Edge. If I manually put in the G4 command in my gcode, it worked as expected but I’ve got maybe 100 files I would have to go back and add that since they were created before I had a spindle.

@hamanjam I was not clear, either. I didn’t mean to suggest going back to 1.1.7. I was just using that as an example of how to go backwards. Like you, I find it odd that doing anything with Edge would affect gSender. Sorry about that, Jim.

No worries. It’s easy to misunderstand online. I do have a question though. You said to reach out to support. What’s the official method of bug reporting? I’ve tried posting other issues in github and on Facebook but it seemed that the forums were preferred.

@hamanjam The forum is excellent, but for tech stuff that goes unresolved, it’s best to open a support ticket on the Sienci.com website.

Edge and main have separate preference files so one should not affect the other.

Are you seeing the delay added in the console (You should see a G4 PX) or just the standard spindle commands? Is it a case of the delay just not being long enough or is it not being sent at all? From our own testing the dwell is still being added on spindle commands.

1 Like

It’s completely ignoring the setting to dwell. I don’t see the G4. Right now, it is moving as soon as the spindle starts spinning up. It was working on 1.2.2 and then it stopped as soon as I started testing 1.3.8. I agree it makes no sense since they should be separate. I rebooted the computer this morning and opened 1.2.2 directly and It doesn’t show the G4 either. Almost like not picking up the dwell toggle option. I tried uncheck/checking and no change. Is there a prefs file I can look at to see if it’s there?

I exported settings and looked inside the json file:

     "spindle": {
        "minimized": false,
        "mode": "spindle",
        "speed": 23991,
        "spindleMax": 24000,
        "spindleMin": 1,
        "delay": true,
        "laser": {
           "power": 100,
           "duration": 1,
           "xOffset": 0,
           "yOffset": 0,
           "minPower": 0,
           "maxPower": 255
        }

OK, I see the problem - the parser is failing your outputted gcode when looking to add the delay because it’s expecting the M commands before the speed… We’ll get it fixed in the next release.

Is that something I need to change in my post processor? I manually changed the gcode for the speed to match what I see in the console from surfacing.

This is the console now (I have a file that just drills 1 hole now so it’s short) I’m using a modified grbl-mm post processor with Aspire 11.5 (I add a lot of notes so I can open a gcode file and find all the info necessary)

gSender - [Grbl]
Connected to COM5 with a baud rate of 115200
feeder m8
ok
T1
G17
G21
G90
G0Z6.350
G0X0.000Y0.000
M3 S19000 G4 P1
G0X100.000Y0.000Z2.540
ok
G1Z-6.250F1016.0
ok
ok
ok
G1Z-12.500
ok
G0Z2.540
ok
M5
G0Z6.350
ok
G0X0.000Y0.000
M2
ok
ok
ok
ok
ok
ok
ok
[MSG:Pgm End]
ok
G4 P0.5
ok
feeder m9
ok
feeder G54
ok
force ok
force ok
drill1.gcode (835 Bytes)

We’ll handle either situation on the software side so nothing you’ll need to change.