gSender 6.8 not completing Homing Cycle SOMETIMES

Ok, So your going to think I am nuts, and full of it.
But I got it on video, so I figure I am going to report it.

I cant say this enough, I have seen this happen 4 times out of the 10 times I have tried it. I can answer questions, but I dont know what triggers it.

I am running default Homing on my Rig ($23=1) however, I was able to reproduce the problem manually.

Basically, I am seeing, my Longmill, Homing the Z, then Start Homing the X , the Y Axis DOES NOT MOVE AT ALL but the X and Y should move during Homing.

Then when the X switch is trigger, the System Errors. and an ALERT is given.

THE ONLY fix I have seen work, is to just keep retrying.

***** I have seen this behavior start when gSender first launches, however, I am reproducing the problem with a $h

In the video, You will see, that:

  • I issue a $h command. (00:13)
  • The Z Axis homes as excepted (I can NOT confirm this happens every time) (00:25)
  • The X axis starts to Jog , Important to note, that the Y is not moving at all at this point (00:28)
  • The X hits the limit switch, it should bounce back 10mm (my settings are set this way) and then do a Slow jog back to zero (00:31)
  • however the environment errors out. (00:40)

I tried to figure out how to make it do it, but I cant, after trying to $h a few more times, it starts working and all is good.

I went out into the shop to re-test it after being off for 4-5 hours, and it worked just as expected.

I have experienced this 10-20 times in the last 4 days?

I dont belive I have seen this behavior in 6.5 , I didnt have 6.6 installed very long. I have seen it in 6.7 and 6.8

I am out of town after 1pm Friday, if there is a Log or something I can provide please ask asap.

back on Sunday around 5pm

This sounds like a wiring issue with the Y switch.
Can you send a ? through the console and report the response?

I am not saying its NOT a wiring issue, because frankly I dont know what it would be, so I am open to it.

However, I can move the head in any direction, and when I home, the Z moves, the X moves, but will stop once the X switch is trigger, and the Y axis never moves.

So, once I clear the error, all of the Axis move as expected with the jog controls.

so, I would be ok with a wiring issue, my question is::

if the $h command is supposed to:
1 - Home the Z axis,
2 - Then Starts moving the X and Y to zero,
3 - Then when the first switch is hit on either axis, that axis Stops,
4 - The other Axis continues to Zero and then Stops,
5 - then the X axis starts to do the Slow jog to zero.
6 - then the y axis starts to do the Slow jog to zero.

What condition would be, that the Y axis doesn’t move, and the X axis limit switches stops moving on the first trigger.

I cant think of a condition that would cause this.

I am open to idea’s

as well, it randomly works too, so its possible its a connection issue, I dont know enough of the environment to be able to troubleshoot at that level

Your Y switch is in an active state (thinks it’s pressed). The reason homing falls is because it fails to clear when it retracts.
Wiring issue, bad switch, or some sort of EMI.
Send the ? before you home…I bet you’ll see Pn:Y

The homing action happens on the grbl controller…gSender has nothing to do with it once it passes on the $H command.

Ok I will give it a shot the next time I see it.

I remember someone saying somewhere there is a command to constantly echo out the state every second.

By chance anyone have it handy?

Okay so using your information I had a chance to test but you were suggesting

And it looks like if I hold the y button when I do the homing action it reproduces the scenario that I’m experiencing

I’m not sure if that’s the problem because I haven’t been able to reproduce it by itself.

So for the time being I’m going to assume as you suggested the wire switch is stuck on until I can prove otherwise

Thanks a bunch makes sense now

1 Like

Hello!
I have totally same problem after 6.8 update and I couldn’t solve it. I canceled the home switching sensor connections and reset my board. Now I am not able you use this function. :frowning:

If you a ? In the console window, and the copy paste everything reported here. It will help

@Menglor Did you do that yet? Did yours show the Y switch triggered?

@NeilFerreri

I have been at the cottage a few days , I haven’t been able to do any testing

Ah, a nice break from tracking down CNC problems.