Gsender freezes once the router is turned on

Hi all, I have my longmill MK2 last October. I was using Gsender 1.1.4, everthing looks ok when I started, only the machine was always stopped in the middle of job. I had posted this issue and been instructed the dust collector need to be grounded when use it.
After I update Gsender to 1.1.7, it shows connection problem. I restore default Gsender settings, then the machine back to work. but now I try to use Gsender’s surfacing function, get everthing ready to run. I have found if I run the program without turn on router, it works find from A to Z, but once I turned router the Gsender is freez there,out of control. I try to disconnect and re-connect, then shows “open com3 error”, after a few Second, I can hear the sound from laptop, then I can re-connect to machine.
I have even restore my laptop, but same situation as above.
I have read others issues, and followed OPs58’s step to check all the connections, take to router cable out and grounding the dust collector, but still doesn’t work.
Does any of this family member knows how to fix it, I really need to your help.

Have you tried replacing the USB cable? I know a lot folks have had issues with the cable.

I had tried before my laptop restore, I will try it again. thank you for help.

I have the exact same issue; my MK-2 freezes soon after initiating a carve - either while travelling to the beginning of the carve or during it. The ONLY thing I have had success with is significantly slowing down the carve feed-rate to 20% or less. There also seems to be benefit keeping the X-Axis lead screw well lubricated.
I do not have this occur with all carves; just ones that I have repeated certain projects. That makes me think there is a possible software issue in either gSender or V-Carve Desktop. And yes, I have replaced my cable to a quality EMI shielded one. Finally, my dust collector is not the problem. I ruled that out by keeping it and any other electrically powered device turned off - and this problem still happens.

Hi Bill,
Thank you so much for your comments, the EMI shielded cable is great idea, I will try it.
meanwhile, I would like share my experience with you, I learned from Sienci Lab is that keep router and control pennal in seperate circuit, I tried and it worked well.