Gsender Freezing up

Yesterday I was cutting a long hour job. I had to pause the job, and turn off the router because I was leaving the CNC area. I usually have no concern with doing this, unless of course I lose power. However, when I came back, the router was still off of course, and Gsender indicated it was “running,” however, it wasn’t. The lines weren’t counting down, and the job cursor was not moving. So when I attempted to press any / all buttons, no response. I had to actually shut the system off. Gsender was froze and…crap! Upon restarting the computer and gsender, I was receiving an error something like, “can’t connect to server,” which I had never seen previously, quickly then it would go away, however it would not open any files. So of course in the middle of the job I had to switch to UGS :((

I did notice some people on Facebook group were complaining about Gsender freezing. Anyone else having difficulties?

@chapklc Kari: Be sure to write up a google form and send this in.

Just a question if you don’t mind. You turned off the router and paused the job in gsender. Since gsender was paused, why would you expect the lines to be counting? Another question (I lied about there being only one.). What was giving the error message, gsender or windows?

So when I returned to the project, I turned on the router and went to click on “resume” on the software…however, when I looked up at the screen, Gsender was in “running” mode. And the pause button was showing not the resume button.
I thought crap, I didn’t hit the pause button the first time, but I know I did, because the router itself paused as requested.
So I looked to make sure it wasn’t counting and the cursor wasn’t moving. It wasn’t.
The error was on Gsender upon starting. Like I said, I had not previously seen that message.

I only have the version 1.0 google form…
Don’t have the current one.

@chapklc tks,Kari. There is an icon in the upper right corner of gsender that opens the google form.

Oh yeah, I had forgotten about that!

Hi @chapklc, I just wanted to follow up with you on this thread to see if this issue is something that you were still experiencing or if I can consider it as solved :slight_smile:

that one actually is fine, but on the new 6.9 version, within minutes of starting the program I am unable to jog. And I have to keep uninstalling the program and reinstall version 6.5. Is there any way we can disable auto updates…? I would like to have control over when I actually update the program.
Because I haven’t had ANY real issues lately except with version 6.9.

Hmm, I’ll look into that problem.

Starting on 0.6.8 we disabled auto updates but that means that all the old versions still have it enabled unfortunately.

can we physically disable it. Every time I start 6.5, I have to remember to turn off my internet so that it does not auto update.
Any word on your next upgrade release… and is anyone else reporting problems with this inability to continue jogging?

Because of the way the previous versions were built there’s no way to disable the auto-updating on the previous versions. As of now the new version of gSender is now out now though! No feedback yet on the jogging bug but we’ve tried to implement a fix so I hope that it’s been taken care of now

I don’t have the information in front of me

But if you get the host name of the server that’s trying to update your build

You can block it in the host file on Windows that way it won’t ever be able to communicate with the update server

I can walk you through how to do it I’m just it’s a suggestion to get around this problem for now

1 Like

Ah, Chris thanks for responding… I had such the devil of a time with 6.9, causing endless heartache! I’m very glad to see 7.0 out… I’m in the middle of a carve, and Lordy, 6.5 has done froze up… but is still cutting. I’m hoping it will continue to the end, cause I don’t want to have to start it all over again… :::sigh::: I will install 7.0 when I’m done. THANKS again!!!

1 Like

Menglor, I’m so hoping that version 7.0 fixes the bug… whatever it was. BUT I will hold you to it, if it continues to be a problem! Thanks

CHRIS :sob: it’s still doing the freeze or lose connection (requiring a “reconnect”) when jogging on ver 7.0. Additionally, it is also stopping right after I start a cut… and then randomly it will freeze while running the program… none of which has occurred previously.
So I’m back to ver 6.5. For me, 6.5 seems to be the most stable version of late.

1 Like

@chapklc Ok, good to know. It’s not what I wanted to hear but it’s necessary to know what is and isn’t working.

On the upside Kari, we just released an even newer, newer version of gSender today! We’re feeling even more confident that this one has fixed the reported problems :pray:

1 Like

thanks for the update Chris, haven’t had a chance to change over to the new version yet. I want to finish this carve and then I will try…

1 Like

@chapklc has the newest version fixed your issues?

Yes, I haven’t had any issues with the latest version!!! Thanks Chris!!!