gSender Homing Issue

Another newbie issue. When I start gSender and connect to my machine (Gemnitsu 4040), I do not have access to the Homing Box showing on the screen. Its not until I move an axis to its limit switch and and the machine faults, that the Homing section appears. Is there a way to have this available all the time?
All help is greatly appreciated !!! Cheers

Have you got the Homing Cycle enabled in the firmware settings?

Yes everything other than the soft limits was enabled. Turned them on, but doesn’t seem to make a difference - after I restart the software there is still no homing icons available.
I did discover though as soon as I click on the Firmware icon and that window opens, the homing options appears in the background. Close the Firmware window and I’m good to go. May not be correct, but its better than having to run an axis to the limit switch. Thanks!!!

@Turdmagnet Did you use the firmware tool in gSender to flash the eeprom on your gemnistu controller?

Yes after I enabled the Soft Limits I reflashed the eeprom, but after reloading the software I still don’t have the homing functions available. I’m wondering if it has something to do when the machine connects to the software or visa versa. I normally have the machine powered, then start the software, and once its loaded its show connected on Com4 and I can use all the controls (less homing). When I go into the Firmware tab, it shows “You must be connected to change eeprom settings” and a “Connect on last active port” button in the center of the screen. As soon as I click on the connect button the homing controls are active. So I’m thinking that somehow the software is not connecting fully. Its got me stumped !!!

@Turdmagnet What profile did you choose in the gSender firmware list? I would think that you should have chosen Sainsmart from the list, but I don’t have you machine, so I can’t be sure.