Gsender is being very slow and lethargic?

I have version 1.2.2. Is any one experiencing this lately.
Last weekend my x carriage ran into the side cause it wouldn’t stop. I didn’t think anything of it thinking it was batteries in my remote.
This weekend I am having problems just operating it manually by the computer. It takes about 2 minutes for it to respond to anything. I can’t even move the graphical representation. Just a few minutes ago it ran my bit into the material being so slow to respond.
It has shut down my operation. Does anybody know what I can do?

I’ve had a couple of instances where I use the xbox controller to jog the X or Y axis a small amount and it just keeps going until it hits the limit switch.
The worst one was i just started moving the Z axis down in 0.1mm step to Zero it on a block of aluminium and it just kept going down and smashed the bit.
Its only happened 3 times and its intermittent and usually happens just after turning everything on ie. first up movements.
I put it down to a xbox controller blip but maybe it is gSender if others are experiencing it.

1 Like

Mine has done that too.
But at that time its barely reacting to actions I take on the computer. I wasn’t even able to rotate the graph, control the speed…
Anything I did gsender would take about 2 minutes just to respond. Because of this and other instances I’m thinking of trying something else.

That makes two of you with a similar experience. Perhaps instead of dropping out, you both might find something about your systems that are similarly configured?

While troubleshooting a problem, remember that there are quite a few folks that use gSender without any major problems.

@iwannaapple @Lappa I’m sure that tech support will be able to offer some suggestions if you open a ticket.

As a start, I would suggest two things. Re-install 1.2.2. Then, try the GUI jogging controls in gSender without first using any of the controls on the xbox controller. If gSender behaves that way, then try using the xbox controller. If it misbehaves, try the GUI controls again. If gS now misbehaves, you will have narrowed the problem down to something inherent in the xbox controllers. That will, I believe assist tech support when you contact them.

As I said, it was just a couple of instances, not an on going problem. At the moment no problems with many jobs run. If it reoccurs and becomes a problem I will investigate further.
I was just answering someone’s query on whether anyone had seen something similar, not posting a problem.

1 Like

I don’t know what your referring to when you say “g5”.
I don’t have the xbox controller but that doesn’t matter. I was using the Gsender’s controls. Not even the visualizer was responding in maneuvering my project.
I will try to reinstall.

After all, that is what a forum is for!
Thanks.

Or maybe its a gSender blip. I’m using one of the tested controllers and mine is doing the same thing. 2 different controllers but same gSender.
I’ve also had problems when probing so I don’t even use the aluminum block thing anymore. Don’t want to buy anymore bits and it damaged my z-axis carriage and broke one of the bolts on the inside when it popped. So, moral of the story is keep your hand near the stop button when you probe. If it goes in high gear slam that button down quick! After several instances I still like gSender but I do not trust it all the way.

1 Like

@iwannaapple It is gS not g5. I was referring to gSender. I should have typed it out.

I have had instances where when I hold down the toggle icon for Z on my laptop screen that it will not stop when I release the mouse pad button. I know there is a lag but this was more then a little lag. I have now slowed down the max speed that X,Y, and Z can travel and I have not yet experienced the issue again.

When I tried an older laptop the Longmill was very laggy.

On my new computer with gsender closed and I start gsender it takes a while for gsender to load. (Many seconds) This is an indication to me that the software requires a significant amount of RAM/CPU processing. Gsender seems to function well after starting to starting a gcode file.

1 Like

I’ve been experiencing this exact problem as well. It’s intermittent but agonizing. I’ve found no solution up to this point.

Let me ask everyone here this question. Does anyone else notice that this started after getting the rotary going?

This is when i download gSender Edge. Prior to that, I didn’t have even one problem like this. It may not be gSender either, it could just be the new connections I made for the rotary installation???

Welcome aboard guy :nerd_face:

For me it only happens when I’m in normal mode.

Had it happen multiple times. I only use mouse to toggle the UI buttons in gSender.
It is annoying when it happens when jogging X or Y…but sucks really bad when it’s Z… and yup, busted more than 1 bit now when toggling Z down in Precise Mode.

What I’ve found is that when gSender loads, if it acts laggy at all from the get go, only bad things will happen when jogging functionality is used. Will either not respond for a long time and when it does, it will often continue jogging continually after releasing the mouse button. You have to actually use the Stop button in the middle of the toggles.

My solution is to kill gSender…and start it again. If it starts and seems to not be laggy, all seems to be ok.

I don’t have the slow, lagging problem, just had the uncontrolled axis movement 3 times.
I don’t have Edge loaded and don’t have Rotary.
If I hit the “Stop” button then click “unlock” it appears to fix the problem.
As I stated earlier, the problem hasn’t reoccurred for some time. As the computer is 5 metres away from the CNC, I only use the Xbox controller. I’ll have to move the computer to the CNC and see if I can reproduce the problem from the keypad or mouse.

Have you tried running in lightweight mode with all features turned off? This was happening to me too and when I looked at the computer resources it turned out that the visualizer was maxing out my GPU. Once I turned the visualizer off everything was instantly better. Sucks to not have a visualizer, but I’m happy with the improved performance. I use normal mode with visualizer while setting up a project, and then switch to lightweight mode right before running it. Hope this helps.

That’s the first time I’ve heard of an improvement via lightweight mode. I’m going to try that, too.

Perhaps Kevin can comment? @KGN