Gsender is not working in the Z code

When I set my z code and start my project,the machine will go to the start position and then plunge straight down into the wood about a 1 1/2 inch and of course can’t move. Anyone have any suggestions. Is it in the control box or Gsender.

could be a couple of things:

is depth set correct in your s/w?

Is the output of g-code correct i.e. grbl in mm or inches?

using correct tool path/settings?