Gsender says connected, but not fully connected

I just received my MK2 and have set it up, but not made any cuts yet. This issue started from the first connection and is consistent with two different computers, MacBook air and Microsoft Surface. Both of these are computers I use with my laser cutter (not Sienci) running Lightburn, so the USB ports are fully functioning.

Some times I can connect up through G-Sender fine and use all controls. At some point it will get disconnected, but the box in the upper left will be green and say connected. None of the controls will work. Some times when i try to connect I will get the “humm” from the Mk2 and the box in the upper left will be green and say connected, but the box in the preview screen will say “connecting” and all of the controls will be gray. If I go through several iterations of restarting G-Sender, turning off the MK2, unplugging the USB, it may actually connect up again. I am unsure which part of the reset is what actually make is work again. One strange thing is that when the MK2 has power and is not plugged in to a USB port it does the “humm” constantly.

When I first set the MK2 up it connected the first try, then after a few minutes it started the not responding thing. The USB cable is obviously making a level of connection between computers and the MK2 every time, and since it is consistent between two computers running G-Sender, I don’t think it is a software or computer issue.

Other than swapping out controllers I don’t know what else to do.

Hello! Sorry you are having problems @PGW18902 . My suggestion John is do a ticket with Sienci. It does appear that you have more of a problem than we can handle in the forum. Especially with you trying two computers. The support staff are good folks, and will help get you on track quickly. Let us know how it all works out for you!

Have you tried a different USB cable? It’s probably not the problem, but it’s easy to try. Also, I’ve heard of several instances of the Arduino board in the controller unseating. You might want to open the control box up to the point where you can check. It’s socketed so just make sure it’s plugged in properly.

Do you have the limit switches installed? Are you getting alarm errors?

1 Like

Which of these laptops drop the usb connection or do they both do it, equally?
It may be a case of power management by the laptops. Just about the first thing they do when idle is power management . Have you looked at those settings in your operating systems?

1 Like

Yes, limit switched installed, but it was doing this prior to installing the switches. I don’t have an extra USB for this, may go get one tomorrow, but even when the controls don’t work the USB is connecting because I hear the “humm” when I press the connect button. This happens with both laptops and I use these both of them with Lightburn on my laser so I know that it is not the computers.

Open the controller and make sure the board is seated all the way in. They can come lose during shipment.

@PGW18902 any update?

Sienci gave me a trouble shooting list. Board seemed to be seated well, so I swapped out the USB and that appears to b working with my Surface Pro. Yesterday I was able to stay connected for a while and did several disconnect/reconnect sessions and it always came back online. I’m going to run some test cuts today to make sure it is still working well. The USB cable I have does not have the ferrite cores on it though. I don’t know if that will be an issue later on.

1 Like

Well, I thought it was a USB cable but it is not. Issues started again, but it seemed to not disconnect while I was running test jobs. So I ran a surfacing job of 35 minutes and it stayed connected the whole time. I came back about 2 hours later do do more surfacing passes and it would disconnect on me about 5 minutes into the job. This happened three times. Same job, same computer, same connections as before. I have contacted Sienci support again. Getting pretty upset with this machine at this point.

I have been having the same problem.
I changed my CNC PC to use my personal workstation and the problem seems to have been resolved. I suspect my USB the old PC was temperamental.

@PGW18902 I know that this has been asked before, but have you confirmed that ALL the power saving settings are turned off for your USB ports?

I can confirm that mine were all set to not allow USB to be turned off for power saving. This was a completely new development for me after a couple of months of use.
I did try another PC with a known USB issue (1 of the 2 ports were blown) and needless to say it happened on that PC during a board (10 x 15 inch) I was flattening.

As I say, I swapped PC’s today and had an uneventful few hours of work.

Sienci support shipped out a new controller today. :+1:

I’m having this exact same problem almost word for word, except that when the jogging controls are active… when I click on a control to jog, there is a huge delay before the machine will move then disconnect.

Going to be a few days before I can open it up, to make sure that chip is seated well. Will be in touch.

1 Like

Mine was doing that as well. Seemed like the lag would lead up to the disconnect when I was working.
When did you purchase yours?

I got a new controller in yesterday and am going to swap it out later today.

Just got my longmill just a few days ago. Gonna try another USB cable.

Please keep us posted…

Yesterday I swapped out the controller for the new one Sienci sent me. On my initial spoil board cut it disconnected at line 169 out of 220-something. I was able to recover the job back to the correct line and finished that one. Then I ran another surfacing job and it went all the way through. Today I ran another surfacing job without fault, left it plugged in for a while and cut out two eccentric clamps without a disconnect. Knock on wood…I think I’m fixed.

swapped out the USB cable. Appears to be fully functional now. No hiccups at all.

1 Like

I had the same disconnection problem and got a new controller hooked up yesterday as well. Haven’t done any project yet but it connects now.
The only problem I have is that it still doesn’t work if I have my laptop charger plugged into the same power bar. :man_facepalming:

I think some of these have messed up internal USB ports. I made it a point to use my original USB cable and worked well.

Does the controller pull too much amp for the power strip to have other things connected?