Gsender, SLB, or other?

Running gSender 1.4.7 for about 2 weeks with only issue of start from line not functioning correctly when limit switches active. So I finally installed SLB today that I have had for a few weeks. Ran tests as described in install instructions all looks good. Only issue I saw was even though It showed a 48 30 connected with grbl/hal machine max movements in settings were for a 30 30 machine. Started a job and getting grbl errors #2 and #24. Ran verify code in gsender and no issues noted. Tried running known good files I have run in version 1.4.7 and get errors #2 and #24 constantly. Any pointers to what I should be looking at to rectify issue.

gsender 1.4.7
Longmill 48 x 30
Vcarve pro grbl inch
Laptop running windows 11
connected with usb cable that came with slb.

This is from the Openbuilds forum

" grbl/doc/csv/error_codes_en_US.csv at master Β· gnea/grbl tells us the 24 means β€œMore than one g-code command that requires axis words found in block.”

This means that the controller saw a line like
G1 X5 G3
two Gcode commands, but the G3 is missing an X/Y/Z word, though there shoudl not be two motion G commands on one line anyway.

This tells me you have USB corruption, what is sent to the controller is not the same was what it receives
it means your sender is sending incorrect lines."

1 Like

Thanks Peter, I am going with the corrupted usb port or cable as everything was OK prior to installing the slb.

What controller were you running before you installed the SLB? Was it using grbl or grblHal?

I was running the longboard with grbl connection

Having tried 2 other usb ports and getting same issue I replaced the cable and files run fine now.

@Mickus Since you have resolved your issue, I am closing the topic.