gSender v1.0.1 and v1.0.2 Release

Hey folks, small build today to fix some recurring issues we’ve seen crop up over the past few weeks.


  • Fixed issue with XYZ Probing profile not moving in the X direction as far as it used to
  • Fixed issue where changing the plate dimensions resulted in a crashed app

1.0.1 - What’s else is new / fixed?

  • Rapid position buttons now use EEPROM values for more accurate movements and machine profile limits should be set from EEPROM values on connect
  • Spindle rate hidden by default - Spindle/Laser must be toggled on in machine profile to view overrides during job run. By default, it will only show feedrate override
  • Surfacing tool now runs last pass in Zig-Zag pattern
  • Added support for $13 in feedrate reporting so your units appear consistently
  • Safe height should no longer send router to Z0 and instead move down relative from current position
  • Added new machine profiles for Shapeoko and others. Added a generic GRBL board if you don’t have a machine on our profile list.
  • Fix for F-key shortcuts not working
  • Added some missing units throughout the UI
  • G28 commands no longer ignored
  • Alterations to XY probing
  • More accurate error line reporting

We hope these updates make a positive difference to how you use gSender. It should also make it better to use for other CNCs outside of the LongMill.

Within the next few weeks we want to really flesh out any other impactful bugs or features that remain in gSender:

What are you having issues with? What do you want to see?

It’s from feedback from all of you that we can continue to make gSender (and by extension the LongMill) better and easier to use for everyone. If you’ve given us feedback before and you feel we haven’t yet addressed it, then post it again (maybe we misplaced your comment). We want to get to the point that everyone using it is happy with what it offers to them :+1:

Also, even more updates have hit the gSender documentation with more still on the way. Give it a read and watch out for more:

I have noticed there’s quite a bit more people on the Facebook group than there is in the forms

I think it would be a good idea to post this link in the announcements so that people are kind of brought back to the forums talk more openly about the technical side of things

There’s usually a sister post on Facebook by Chris for each version - I’m sure it will be coming sooner rather than later!

  • It does look like GoTo issues are fixed in 1.0.1.
  • Inconsistency: M0 brings up a flashy dialog during tool change code and the simpler one during Gcode execution
  • Repeating my feature request that comments on a M0 line show up in the Pause dialog of whatever form
  • Note: I see elsewhere that G4 (dwell) with an S argument is measured in seconds and for a P argument the units are milliseconds, whereas they are both treated as seconds here. I don’t know what is standard or if there is any and the risks of changing it might be substantial.

I have posted this in the Facebook group, but I thought I’d put it here as well.

I have experienced static charge triggering my Z limit switch twice tonight while my bit was plunging 1/2 deep so I know it wasn’t possible. It also appears my Z height was changed as the limit switch was triggered. I have read about grounding vacuum hoses but I have not discover any reliable methods to achieve that. My work around was to turn off my hard limits in order to continue on my carve. I would like to request a feature to turn off XYZ hard limits independently so I can still make use of my XY switches if I had to turn off my Z hard limit. I have a feeling most who is experiencing this issue comes from the Z limit switch as the X and Y are too far away from the vacuum hose.



A little off-topic, but there are static control vacuum hoses available, or you can actually run a bare wire on the inside of your present hose. Ground it to the chassis on both ends. Changing the machine is not going to improve static problems.

1 Like

I can’t speak as a rule

But it’s beeny experience that there is 2 reason the Z height can change.

  1. If your linear block is dirty, and it’s moving and it binds, the actual height will be trying because it tried to move the head and it didn’t, but the software didn’t know it

Fix. Lube the linear block.

2 if ever your running your mill, and you pause or. Switch blocks, tool change …
Basically when the head stops moving , there is a countdown before the motors turn off. If that happens weight, nudging or tool change can alter the current z, x or y as well.
Fix. Set $1=255

If you think it’s static, option 3 is run it without the dust collector and see

I updated gsender last night now having issues with touch sensor , X and Z are fine Y hits hard and an error occurs

Thanks for replying, this is a relatively new setup and I clean and lube the system every week, I don’t believe the issue is the binding. I have disabled my hard limits and it’s been running fine for the past 6 hours. The longmill is enclosed and the long board is a foot away from the enclosure as well. I have ruled out other possibilities that could trigger my hard limits and hence hoping to see if we could enable / disable them individually so I don’t have to stop using all of them.


Adding a switching inline with the wires would be a good test. Or a series low pass filter - that might alleviate the problem entirely. I would try something like this Screen Shot 2021-11-27 at 3.58.28 PM or this Screen Shot 2021-11-27 at 4.03.25 PM

1 Like

Would love to see option to execute a macro on tool change.

1 Like

Is the only way to download the update from the program or is a updated bundle that can be downloaded from the website?

normally its uploaded to the website as well, but @chrismakesstuff is responsible for so many things, we have to make fun of him and he fixes it.

just kidding, it does happen that he is just too busy. I referenced him here in the thread so he knows about it

Opened a github issue, but more information on how/what macro variables are available.

Agree with above, execute macro on toolchange.

Since updating to 1.01 I’m now having a issue with the probe plate ,when zeroing for XYZ . Z completes fine, when traversing for X it stops in X before it is off the plate and plunges into it. All settings appear to be set properly and worked fine in version 1.0 . I have switched back to version 1.0 and is now working properly again.

Releases · Sienci-Labs/gsender · GitHub

Not going to start a new thread since this version mostly contains probing fixes, but 1.0.2 is release with a fix for the XYZ probing regression as well as the black screen when changing probe dimensions.

As always, it can be found on Github.

1 Like

Just got gSender working on a Raspberry pi 400. Looks sweet!! I’ll test it tomorrow on some jobs.

1 Like

In settings, on the tool change tab there are three options on what will occur when a tool change is called out.

You can write pre and post tool change routines.