gSender wont stay connected

gSender 1.1.7 running on a new acer laptop with Win 11

New user here, just assembled my 30x30 a couple of weeks ago but everything has been working fine since start up. Today when I went to fire up the Longmill I’m unable to get gSender to connect.

gSender opens normally but when I hit the connect button, it will either connect for a brief moment, just long enough to flash the “idle” then disconnects or it will just get hung up on "connecting "
Tried shutting everything down then restarting laptop, gSender and the longboard as well as checking cables and swapping the USB cable out. Everything appears ok. I haven’t gone as far as pulling the cover off the controller yet.
Any ideas for next steps?

Make sure in the laptop that the usb settings are NOT set to go to sleep after a short while. Hope that might help.

So it sounds like gSender is waiting for a signal. I suppose it is possible the arduino board has come loose but before going to the trouble of opening up the cover to check. and knowing Windows laptops are notorious for usb issues. I would first try ensuring screen and usb are set to never sleep, then delete the usb drivers, do a restart and windows will reinstall drivers and try again. Good Luck.

1 Like

Thanks for the directions
It definitely is a laptop issue, I hooked up my old one, loaded gSender and it will stay connected.
Checked the USB settings and they were enabled, now disabled but that didn’t help. It still connects for a 5 count then disconnects. Going to check the settings and drivers on the new laptop a bit further.

Its a bit of a pain as I convinced my wife I needed a new computer because the old one was giving me problems!

Tried everything I could think of with drivers and cables. I even tried gSender Edge but always got the same results. I could connect , but after 5 - 10 seconds the indicator thst shows in the visualizer would show disconnected while the top left would be connected.
Then after a day of trying different things… its working, or at least it stayed connected for10 minutes before I called it a day and settled in with a beer and a hockey game.
I’m a leafs fan so am familiar with frustration!

Other folks have reported similar issues with Win 11. I don’t recall seeing anyone find a cohesive source of the problem. Win 11 seems a little bit glitchy when it comes to its connection to arduino based machines sometimes. Fingers crossed that you have it sorted out.

1 Like

@Minidb I had the exact same issue in January, just like you new laptop windows 11. I even contacted HP tech support but they coul not figure it out. I replaced usb cable 3X. I ended up replacing my bluetooth mouse with an old wired one, I have not had a connection issue since. I cannot explain, nor can HP, why this worked but it has.

1 Like

Groundhog day…
Neither gSender or gSender edge will stay connected this morning.
Recap of things tried:
All USB and PC “sleep” settings disabled
Un-installed and re-installed USB drivers
Un-installed and re-installed gSender
Un-installed and re-installed gSender Edge
Tried with and without internet connection
Multiple restarts of Win 11
Multiple cable swaps
Cycled through all 3 USB ports at least twice
Check to ensure cable connections were solid

(I should mention that when I switch to the old Win 10 laptop , it connects every time. I would have stayed with that one but more often then not it takes forever to boot up along with other performance issues. )

But hey, cant really complain, the sun is shining, its only -4 so we’re off to walk the dogs along trails in the Canadian Rockies!
I play more later this afternoon.

@Minidb If windows 11 is using its generic usb drivers, I would download and install the “genuine” arduino drivers from arduino. Just a thought.

Ill give it a try, the next step will be to install Win 10 rather than 11
Can i just get the drivers or do I need to install arduino IDE?

@Minidb I’m not sure. When I got the drivers, I was also getting the ide, so I never looked to see if I could get only the drivers.

No luck with drivers, actually I couldn’t find them after id downloaded Arduino. Hidden files I suspect.
I gave up looking and installed Win 10 but that didn’t work either.
I’m going to return the new Acer laptop tomorrow and see what else they have.
It had an AMD processor so I’ll try Intel…

Exchanged AMD chipped Acer laptop running Win 11 for similar ASUS with Intel chip running Win 10 and we’re back in business.

@Minidb Strange, but I’m glad to here that you resolved your issue, Doug.

As your issue is resolved, I’ll close this topic. Don’t hesitate to start others when/if other issues arise.