HELP ME PLS! Longmill loses square suddenly

So my Longmill started doing something very, very strange.

It binds and loses square on the y axis, but only mid toolpath, and only when it’s recentering to start another pass on a clearing toolpath.

See video (only 40s long)

I have tried to replicate this by cranking the jog speed up and switching directions as fast as I can back and forth with jog control. It never misses a beat.

I have readjusted my backlash nuts (been using this regular for 2 years, have tuned the machine several times and never had a problem).

I have cleaned wheels, rails, screwgear…

This only happens when it’s running code.

So, I get my gcode from Carveco and I save as UGS MM (.gcode); I have tried other save options like .NC and others, but still have the same problem.

Anyone else seen this? Its repeatable and only binds when recentering to start taking off a new layer.

By any chance did you check the lead screw couplers to see if the Y is loose, and slipping?

can check that, but I hear the stepper motor clicking the same as when you run past the end of travel.

And that wouldn’t explain why it doesn’t replicate when aggressively jogging back and forth at highest speed.

What you’re describing sounds a lot like your stepper is stalling. Maybe you’re pushing it too hard for the material, have done so in the past and weakened it, or it’s simply failing?

@HarndenWoodworks It has come up in the past that the motor shaft has broken. Movement would still take place, but would be intermittently off. Can’t hurt to look.


I think there is an internal problem with the zeroing code.

It fouls up every time the
command happens.

I am zeroing on the center of the project. After it clears each layer it gives the G0X0.0033Y-0.5441 command and that is when the left side Y axis stepper binds.

The only thing I can think of is that the G0 command moves at max speed. For some reason the stepper binds.

Is there a way to set the max speed the machine uses when it gets the G0 command to test this?

will check that but it can move with ease with my 200 lbs pushing and pulling against the gantry while moving. Also continues to happen when “AIR CUTTING” the pattern.

@HarndenWoodworks You can set the max speed in gSender.

The settings you are looking for are these:

$110 = 4000.000|X-axis maximum rate [mm/min]|
$111 = 4000.000|Y-axis maximum rate [mm/min]|
$112 = 3000.000|Z-axis maximum rate [mm/min]|

You can change any or all of them. G0 will move the Mill at those speeds. If it doesn’t help, you can return them to where they were.


I noticed also that movement on the Y-axis was really hard and clunky, not smooth.

I went into GSender and went to the Firmware setting and told it to reset to factory (I have never been in those settings before, so I don’t think I accidentally changed them).


In fact after all the maintenance I did to try and find this problem it works as good as new.

So, I use a little tablet windows computer that only has two programs loaded on it. GSender and Lightburn. This computer only runs my longmill and my Xtool D1.

I think I accidentally sent some code to my longmill from Lightburn that changed the acceleration rate to something far beyond what the Nema23s on the longmill can handle with the weight of the router.

If you have a D1, you know it can accelerate VERY fast compared to the longmill. (which makes sense as the lasers are tiny and light compared to the router.)

So, there we have it. The acceleration was changed somehow and even though the 2 steppers for the y-axis are the same, one could handle the movement, but both could not, causing the racking in my gantry.

Now it ramps up from 0-70 ipm instead of just hammering the gas.

Thank you all who game me suggestions. And anyone else who runs multiple g-code machines from one computer, be sure not to send the wrong message to the wrong machine.

Be well everyone,
I have some chips to make now.
Harnden Woodworks

1 Like

@HarndenWoodworks Great news, Phillip! Have fun.

As you resolved your issue, I am closing the topic.Anyone with a similar issue is encouraged to start a new topic with your details.