Help understand gsender/Grbl

Fairly new to gsender so have a few questions?
I have gsender setup for inch mode on the work area
When I jog everything is good it moves what ever the pre sets are in the jog control. And it displays in inch.
However if I use the console and move using the
G0 command it shows the movement in inches but the command is in mm. Another words if I type
G0 x1.00 it’ll move 1mm and not 1". But using the jog control works and displays fine??
If I enter a G20 then all is well after that… but aren’t the settings for work space suppose to take care of that?
I have also tried playing with the $13 = setting but no difference.
For you pros, should 13 be 0 or. 1 for inch mode like I said have tried both …

Preferences units only effects what the application displays to you (metric or imperial). It does not effect what unit modal the firmware is in.

If you want the firmware to move in inches, you need to swap the unit modal from G21 (metric) to G20 imperial. G21 (metric) is the default modal value on connect/board reset.

$13 effects nothing in the application because the values are just converted before displaying behind the scenes.

1 Like

Thank you,
So by default grbl starts in g21 mode if you want to use in inch then you need to give it a g20…?


1 Like