Home button disappeared / can't find

I’m completely new to cnc/gsender. It is the first program I’ve ever used. I installed, home button was there. Then it said there was an update…now the button is gone. Your documentation says

“As long as homing cycle ($22) is enabled on your machine you’ll notice additional buttons appear in the ‘Location’ area of gSender”

Does that mean you guys want me to buy it? I can find 0 information about this online. What is required to be purchased to use?

@hendr1x Do you have the limit switches installed? You do not need to have them. (I don’t). They are an add-on to the standard Long Mill.

I am not sure what you are referring to as the Home button since I do not have the switches, and don’t see a Home button. Others here will no doubt jump in.

You mention a gSender update. What version are you running? The lastest version is 1.4.4.

You might tell us what machine you are using as well as what software version of gSender.

see image below, happens to me all the time
if top left is connected (Green marking), if not, find your machine, then
click top right on firmware (red marking)
then if you have the button on (blue marking) , click that and home button will appear

@CrookedWoodTex Good point, Tex. I jumped too soon.

I am trying to use a Genmitsu 3030 which has endstops on both sides of all axis. I will attach a screenshot that shows I am connected but homing is disabled. I tried googling for a while and could find no information on how to enable. UGS works perfectly so I don’t think it is anything to do with my machine. Any help would be appreciated.

You need to enabled $22 (homing) for any functionality that requires homing to appear.

In the firmware tool, toggle $22 to “Enabled” and hit the “Apply New Settings” button.


At this point, UI homing functionality will appear in the Location widget.

1 Like