How to tell if your control board is bad

What are the signs that your longboard cnc control board is going out. cnc is not responding to gsender commands. No problems at all since installing the cnc and gsender until now. Been working fine for 4 years aprox.

Hi Mike, welcome to the forum. I’m sorry to hear about your problem. A couple of things for you.

  1. Has anything changed? New update to your Windows computer?
  2. Do you have the ability to switch out computer and try another one? How about the USB cable?
  3. When you turn on the panic button, does your LongMill board light come on?
  4. Did you upgrade GSender recently? (Grasping here)
  5. Does GSender appear to be working when you attempt to jog? (Trying to decide if GSender is functioning right)

Let us know, we will help as much as possible. If you come up with a solution, by all means post it.

Best of luck sir!

Thanks Jake, I am busy troubleshooting all of your suggestions starting with the simplest ones first. I just replaced the USB cable and am trying this first. Panic button seems to be working fine and yes the board lites go off and on. Now to say what messed everything up from the start, I went to github to ask for help and picked up a bad virus. After trying to re download gsender I was getting a blank screen. The program was loading but nothing showed up when clicking on it. Got a new computer and downloaded gsender and that worked. Got it up and running yesterday but then this morning it was all whacky again, so I just put a new USB cable on and it is working O.K. Will keep you posted as I test. Thanks Michael levine.

1 Like

Jake, I now beleive that the gsender program is not working properly. I am going to undo 1.4.3 and try to install an earlier version. Will see if that solves the issues…

Jake, It did not work properly on 1.4.2. So I went back to 1.4.3. and it seems to be working properly again. I am going to shut it down and try it again in a couple of hours and see…

I had issues with 1.4.3 that went away when I dropped back to 1.2

Jake, Jogging presets in settings on 1.4.3. will not stay at the default setting thus making 1.4.3. not working properly. I am going to try dropping back to an earlier version. Installed 1.2.2. and all is good so far. Will keep you posted.

Probe would not work on 1.2.2. So I am back to 1.4.3. Jogging presets have to be refigured to default everytime I open it up. I am carving a project now and so far so good.

FINAL UPDATE: The problem with 1.4.3. is with the jogging presets. They will not load in inches. They load in mm and change everytime you restart gsender. I have had to step back to 1.4.1. to get the problem fixed. So far everything is working properly. I can’t beleive that all of my problems have originated from 1.4.3. I started off thinking that my problem was my controller but that is not the case. I am still running windows 10 although their have been alot of windows updates lately, I still beleive that the problem lies with 1.4.3.

@mike2 Have you tried 1.4.4? Your issue is one of the fixes it names.

1 Like