I’m new and need help getting started!

Hello everyone, newbie here. I recently inherited a used longmill (30x30), and haven’t been able to use it once. It came with a Dell Optiplex 3010 the sole purpose of which is the CNC machine and has functioned for some time with the CNC machine, though the board hadn’t been used in 4-6 months. My problem started as a connection issue that I was able to determine as a bad UNO board. Anywho, got the new board, flashed it with grbl, and now it’s connected properly but none of the motors work. I can issue jog commands and CNCjs will function like it’s moving but the most I get out of any of the motors is a thumping noise. I’m leaning towards it being a bad controller. I’ve plugged and unplugged all the connections and checked that everything is able to move freely. Any help is most certainly appreciated!

Are you using the correct firmware? https://sienci.com/dmx-longmill/grbl-firmware/

The Feb 25th version should be compatible with all machines.

Yes. I just tried reflashing it with the link you provided, to be sure. Still doing the same thing.

Make sure your jog feed and speed are higher than the default. Also be sure you selected GRBL in the upper left corner of CNCjs. If you are using MM (G21) set to 50. If you are using inches (G20) set to 5. Jog settings are in upper right corner.

One other thing to check. On your controller are the red lights on? Those are for the motor drivers.

Hi there, thanks for responding. I tried as you directed and everything plays out on CNCjs like everything is fine but still, only thumping from the machine. The red lights are all on and everything appears to be seated properly. As far as I know, everything was working fine a few months ago but other than a new UNO board, nothing has changed.

I’m kind of grabbing at straws here but do you have more than 1 com port listed in the connection block upper left? If so try one of the other ports. Also make sure your baud rate is set at 115200.

Just the standard port (COM 1) that doesn’t recognize Arduino. It doesn’t connect at all. Baud rate is good. Just to add, I can hear the electrical hum of the Z motor while idle. Also, when flashing grbl there was one warning error that said there “may be some stability issues?” Not sure if that has any bearing, but whatever helps… I’ve been pouring over this for over a week now.

This is CNCis at startup.

@zheston - Zach, the numbers on your console of the grbl parameters do not look right. Can you post a picture of the beginning of the console list please? Are you sure you flashed with the Sienci file and not the default grbl file? The $110 and $111 should be 4000 not 500 and $112 should be 3000 not 500. It’s easy to pick the wrong file when flashing. That might also be why the motors are not activating.


@Heyward43 At long last, I was able to get the machine moving! I followed the instructions provided in the link and they did the trick. I had the right firmware but clearing the EEPROM from Arduino was what I was missing, I think. I sure am grateful for all the help. I’m sure I’ll have more questions as I prep my first project but I’ll post if I can’t find the info on my own. Exciting stuff, thanks again!


You’re welcome but I’m not sure if I did anything. Maybe triggering a thought perhaps, lol. Glad it’s working. Have fun.

1 Like