Implementing Inductive Sensor Kit

Hello all…

I received the “Inductive Sensor Kit” this friday (Great, since it is a long week-end)

The physical implementation was straight forward and the text and video resources were clear. (I use a 30x12 Longmill Shipped October 2020) (Already 1 Year!)

I selected the “Addin-ons category” in the Forum, but some information/question could be also relevant for the “GSender” Category.

I have confirmed that the cabling is OK (Physical Check + $10=19 Check) (Using GSender 0.74)
(With the September 8 GRBL Firmware)

I have followed the Firmware setting shown in text and video resources. (and added Soft Limits)

And homing (to the bottom left) works perfectly for all axies.

However… some questions:

1-While there is an Active Homing Cycle, the only way i found to stop the MOVE was to use the “STOP” Button on the Longboard. Obviously, i know i can hit the “Emergency Stop” Button. And i did. I was surprised that when i Twisted the Emergency button back (to get the CNC Back on) the Homing Cycled continued. I then Pressed the “Emergency Stop” Button again, removed the USB from the Longboard, powered on again, and all was good. Tried the same steps again to see if i could reproduce and i was not able to reproduce (Sorry)

2-Continuing other Experiments, after successful homing, i moved the router in the Center X/ Center Y position and hit the “Emergency Stop” Button. When i powered back on, using the Arrows in GSender to move back to test the X limit (Without Homing). I was not able to reach the X probe. The CNC would not move. I saw in the “Console Screen” - Error 15 / Travel Exceeded. is this tied a “Soft Limit” behavior, since i had not yet re-homed?

3-Continuing other Experiments, after successful homing, i tried the GSender 4 corner buttons.

3A-From the Home position (bottom/Left) if i hit the Button with the arrow pointing Right/Up, The CNC moves in the Y+ Direction, just for half of the possible travel and there is no X+ move. Does this make sense?

3B-From the Home position (bottom/Left) if i hit the Button with the arrow pointing Left/Up, The CNC moves in the Y+ and X+ Directions up to 1" to max X+. Does this make sense?

3C-From the Home position (bottom/Left) if i hit the Button with the arrow pointing Right/Down, The CNC moves in the X+ Direction up to 1" to max X+. Does this make sense?

3D-If i would NOT be Homed, what would these GSender 4 corner buttons behavior be?

I have no GRBL/Limit Switch/Inductive Sensor Experience before this morning, so any insights to what is going on would be helpful. Any help appreciated. I may have overlooked or misunderstood a step… and explaining those mishaps may help others using the Forum.

Thanks

gSender - [Grbl]
Connected to COM4 with a baud rate of 115200
Grbl 1.1h ['$' for help] LongMill build Sept 8, 2021
client $$
[MSG:'$H'|'$X' to unlock]
$0=10 (Step pulse time, μs)
$1=100 (Step idle delay, ms)
$2=1 (Step pulse invert, mask)
$3=5 (Step direction invert, mask)
$4=1 (Invert step enable pin, boolean)
$5=0 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$10=19 (Status report options, mask)
$11=0.010 (Junction deviation, mm)
$12=0.002 (Arc tolerance, mm)
$13=0 (Report in inches, boolean)
$20=1 (Soft limits enable, boolean)
$21=1 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=3 (Homing direction invert, mask)
$24=25.000 (Homing locate feed rate, mm/min)
$25=700.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, ms)
$27=1.000 (Homing switch pull-off distance, mm)
$30=3000 (Maximum spindle speed, rpm)
$31=0 (Minimum spindle speed, rpm)
$32=0 (Laser-mode enabled as spindle, boolean)
$100=200.000 (X-axis travel resolution, step/mm)
$101=200.000 (Y-axis travel resolution, step/mm)
$102=200.000 (Z-axis travel resolution, step/mm)
$110=4000.000 (X-axis maximum rate, mm/min)
$111=4000.000 (Y-axis maximum rate, mm/min)
$112=3000.000 (Z-axis maximum rate, mm/min)
$120=750.000 (X-axis acceleration, mm/sec^2)
$121=750.000 (Y-axis acceleration, mm/sec^2)
$122=500.000 (Z-axis acceleration, mm/sec^2)
$130=770.000 (X-axis maximum travel, mm)
$131=812.000 (Y-axis maximum travel, mm)
$132=105.000 (Z-axis maximum travel, mm)
ok
2 Likes

Hi all, just got an answer from the Sienci Staff… (@kellyz)

Thanks for getting in touch.

I had just tested gSender with the inductive sensors, and you’re right,
on our end we are seeing the 4 corners buttons not work properly.
This is gSender issue, so we are correcting this bug and will be sending
an update on the program.
Thank you for your feedback! And keep us updated if anything changes.

Cheers,

Kelly

Thank you for the confirmation.

Let’s keep the Topic Open, so we can test back after the next version release…
I Still have to look into Soft limits.

NJ

2 Likes

Hello!
GSender 0.7.5 is now available, and the GitHub Release notes state:

(Excerpt)
Fixed issue with quick movement buttons
Fixed issue with soft limit behavior and continuous jogging if firmware flag to set machine 0,0,0 not set
Fixed issue with imperial units and continuous jogging with soft limits enabled

In reference to Original Post:

-Issue#1 was about Stopping an Active Homing.
I was able to replicate this issue using 0.7.5
While testing, an object was in the way. I had to use the Emergency Stop. Once the object was removed, I Powered back up (Twisted the Emergency Button) and the Homing continued. I do not know if this is a normal behaviour. Note that i use the “Re-Connect Automatically” Feature, as this may be a important variable if someone wants to try to replicate. To Stop it to re-occur, i have to unplug/replug the USB Cable.

-Issue#2 was related to Soft Limits that would either send a “TRAVEL EXCEEDED” of would not allow for “log travels” (or continuous jogging)
This is now fixed with 0.7.5…

Question: Should a “TRAVEL EXCEEDED” FLAG be shown on the Main GUI (instead of hidden in the Console?)

-Issue#3 was about the “4 corners button” (Seems it is to be call the Quick Movement buttons) behaving strangely.
This is now fixed with 0.7.5…

Great job! Thank a lot!

1 Like

This is GRBL behaviour and not something we can stop - once the homing command ($H) is sent to the controller, GRBL takes over to run the cycle and will continue until it complete successfully or fails.

Thanks @KGN
But could you clarify…
I noticed that that “Stop” button on the LongBoard is indeed able to “Stop/Abort” an active Homing.
Unplugging the USB Cable from the Longboard also “Stop/Abort” an active Homing.
So the multiple steps of a Homing Sequence are managed by GSender and not from the Arduino/Longboard?
If so, then when i power back up (By twisting the Emergency Button) and the Homing continues, it is because i use the “Re-Connect Automatically” Feature? Or the Arduino/Longboard continues last action?

No, all gSender does is send a $H to the controller, which GRBL handles - all homing steps are done by the GRBL firmware.

The physical stop button on the longboard soft resets the board which ends the action since GRBL enters the default state on reset - all previous commands in the planner are no longer there.

Unplugging the USB does the same thing since the Arduino is powered by USB - unplugging the USB is a hard reset.

Emergency stop doesn’t reset the board (by power cycling or soft reset command) so the action continues.

Super clear… thanks again…
This topic can now be closed.

2 Likes

Hello all,

I too have just installed the new limit switches.
I am running version 7.5 of gsender and have the same issue when using the corner buttons. If I press the top left corner button the machine moves back 102.87 mm from the home position and stops
Movements are as follows from home as reported in gsender
Top left button Y to 102.87
Top right button y to 102.87 X to 712.80
bottom right button y to 0 X to 712.80
Bottom left returns x and y to 0

I am running a Longmill 12x30 rev 1.4
gSender 0.7.5

Thanks

Hey,

Could you tell/show me what your machine profile in preferences is set to (Width, Depth, Height)? I get correct movements using the 12*30 profile selected.

It looks like it’s using your Z height as the Y limit which makes me think values in your profile may have been swapped.

My 12*30 profile looks like the following:
1230

If your height and depth are swapped, I’d recommend editing it manually.