Inductive Sensor - Homes Fine, but then cannot move (SOLVED - broken capacitor)

Hi,

I have read through all the posts I could find on here before posting, if I overlooked the correct post please link it here. Thank you.

I have the sensors installed (kickstarter board 1.2, with capacitors installed correctly), testing shows they can sense appropriately, and I can run the homing cycle and it homes with no crashing. The problem is that once it is in the home position I can no longer move it. Hitting any of the direction buttons causes it to hard lock. I know I must have something set wrong but I can’t see it.

Through gSender I have updated my grbl using the built in controls. I reset my EEPROM settings to default, and followed the directions in the video and posted in resources. Everything I can tell matches.

I have attached photos of my settings in gSender. I have also have a video of the homing cycle followed by the hard limit locks that I get once homed (Homing/Hard Locking Video). I can move it only by disabling the soft and hard limits in settings.

Any help would be appreciated.





CNC Firmware Settings.txt (453 Bytes)

Just a guess: Increase $27. Theoretically, homing should fail in case $27 is choosen too short. I dont know exactly (cause I didnt try gsender yet), but it seems odd to unlock the machine after homing (think I saw that you had to?). So both could be related to $27…

Thanks for the suggestion however that did not work. Set it to 10 mm and it does the same thing. Now just 10mm from the sensor. So that is confusing as they are so far from the sensors that they should not trigger a hard lock but that is what still happens.

Try turning off hard limits ($21)

If I turn off the hard limits that disables the inductive sensors which defeats the purpose of having them.
I am hoping Sienci staff can help here.

Hm… then next suggestion, home each axis individualy to narrow the failure down: unplugg all sensors except one and home the remaining direction via $Hx $Hy or $Hz. Check if it is maybe related to a single sensor…

Trying this results in this error in the console

in gSender:
client $Hz
error:3 (Invalid statement)

in UGS:

$Hz
[Error] An error was detected while sending ‘$Hz’: (error:3) Grbl ‘$’ system command was not recognized or supported. Streaming has been paused

same result for all axis tried.

Oh man you are right. Single-axis-homing is not enabled by default in the grbl version provided for the longmill.
Maybe now it is time the Scienci support jumps in before I tell you how to adapt the grbl config.h file and upload this version to the board…

I am working with support but not much luck yet. Thanks for trying.

I thought they were for homing…no?
Are you getting an error or is everything just hanging.
The reason I suggested disabling hard limits is to rule out the common issue of EMI creating a false trigger on your limit switches.
If you are not receiving an error, that might suggest a wiring issue with the switches. The fact that it homes and moves to the pull-off position makes that much less likely than EMI issues.

Single axis homing wouldn’t work like that anyway. If set up for homing a single axis (compile time option), you would only be able to home that axis.

@kyfe, Kyle, I think you may have $4 Invert Step Enable Pin set wrong. I think it should be disabled and you have it enabled.

I am not sure what you mean with compile time option. On a different machine I set up with limit switches I can either home ($H or Home-button) all axis at the same time and/or in the desired order (depends on what you defined in the config.h) or home just a single axis with $Hx,$Hy and so on. But I forgot that this second option needs manual ‘activation’ (uncomment a single line) in the config.h.

This option defines how to enable/diable the drivers. High is the default option, which is also shown in the instructions …but you can try :man_shrugging:t2:

Ended up finding the problem. It was a broken capacitor that I found through help with sienci tech support. Working as intended now. Thank you everyone for the assistance and ideas.

1 Like