IOT Relay Activation

Hooked up my IoT Power Bar and edited my header and footer in the GRBL mm post processor in VCarve desktop and it actually works. Using the two normally off outlets, I now have my shop vac and Makita router connected to them. Initially tried M7 but that didn’t work so used M8 to turn on and M9 to turn off.
Connected the Power bar to the coolant port on the Longboard controller, and used this IoT power bar


Good to hear. I just ordered the same. I was a little concerned it wouldn’t be able to handle both the router and Vac.


Single Phase Solid State Relay.

This is the unit I just installed for powering the router. 25 amp relay and DC 3-32V control. Connected to the coolant contact and activated/deactivated with the M8/M9 commands. Works great.


To add, there is now a page discussion IOT relay setup in our CNC resources:


In the Sienci Resources it details the following -

Another option if you’re using CNCjs is to set up custom ‘Events’:

  1. Go to Settings (gears on the left) → Events, and add a new event for the both commands
  2. Use events “G-code: Start” for the M8 command and “G-code: Stop” for M9

This will now ‘inject’ the M8 command at the start of any gcode file and an M9 at the end. It applies to every file you run unless you disable them.

My question, is this feature currently available in gSender and I haven’t found it, or, Will this ability be made available for gSender to have Headers and Footers in new revisions.


Great catch Wayne! Yes this is a new feature that we’re actually working to have ready for the upcoming release of gSender, so you should be able to try it out then :grinning:

1 Like

Has anyone run into issues using gsender with this? I manually add M8 as first line and m9 as last line. When I go to run the job in gsender my router and dust collection power on but the program doesn’t run. If I remove the m8 and m9 codes the program runs as expected. Any thoughts?

@Chrisjsmitty Welcome to the group, Chris. I’m sure that you will find it an excellent place to get answers to your questions.

My answer may not help, but here goes. I don’t have the relay set up, so I just added an M8 command to the beginning of two gcode files. Both ran fine. I can’t see that actually having the relay would matter, but maybe someone here with the relay can chime in.

Have you tried this on more than one file? Can you post the file that is not working? I’ll run it and see if I get the same results.

Thanks @gwilki ! So The relay is turning everything on.

I try multiple files. What is happening in gsender. Vac and router power on, in gsender the job is running in the visualizer. . The machine is not moving however. I delete the commands and runs perfectI have uploaded the file, thanks for the assist! (68.8 KB)

@Chrisjsmitty Weird, Chris. As I said, I don’t have the relay, so my ability to test is very limited. I ran your file and it ran perfectly. Might I suggest a further test on your part? Unplug the relay and just run the file in air with the router dead. This would sort of make your Mill setup like mine. If the file runs, at least we can be sure that the problem has something to do with the way the relay is handling power. I assume that the Mill controller is not plugged into the relay. Correct?

That’s really interesting. I tried your test and it works fine with the iot physically unplugged from the control unit but with the m8 code in the gcode

Try this revised program.
Should work for you. (68.9 KB)
There’s a lot of freaky code here… What’s with all the G1’s ?
What did you create this gcode on ?

@Chrisjsmitty Chris: I don’t have an answer for you on why the presence of the relay is causing this problem, but I am working on it.

@Megistus With respect, Wayne, I would not advise Chris to use the file you attached. It has an M0 command at its start, which will stop the run and not allow it to continue. Further, it has an M05 command that, unless Chris is running a spindle, will do nothing. It turns off a spindle.

I’m curious about your comment on all the G1 commands. I generate my gcode from VCarvePro, using grbl inch as my post processor. It generates a G1 command for every line in the file that is a cutting move, and a G0 command for fast moves outside the material. Does your program do it differently?

@Megistus that particular file was created in easel.

@gwilki my only other thought I am going to try is upgrading the gauge of the wire and decreasing the distance between the iot and the controller to see if maybe it’s a initial power demand issue. I really appreciate everyone’s help. Other than this so far the long mill is running beautifully since I assembled it last Thursday

1 Like

@Chrisjsmitty Chris: Is the Mill controller plugged into the IOT? I ask because, if you are using the IOT recommended by Sienci, its specs say the following:

Note that the IOT relay is built to handle 0-8A with 18AWG power cords and 0-12A with 16AWG cord.

The Makita router draws 6.5 amps and the Long Mill controller draws 8.8 max. So, if the Mill controller is plugged into the IOT, you are way over spec. If it’s not, never mind. :grinning:

1 Like

Wow, That’s crazy. Yes my gcode generator only produces a G command when a change of speed is requested. Thanks for the info.

Thanks for the update. Here’s a 2nd revision to have a look at. (68.9 KB)
The file still runs a bit freaky on NCVIEWER
Have Fun…

@Megistus There is no reason that file won’t run, Wayne. FWIW, I don’t believe that Chris’ issue is gcode related. If it were, his file would not run at all. It does run when he unplugs the IOT relay. I’m waiting for him to reply to my last post, but I think that he is drawing too many amps through that relay and that is why the controller is not powering the motors. Now, all of this is speculation on my part, and I could be dead wrong.

1 Like

That’s why I used my relay as described below.

Single Phase Solid State Relay.

This is the unit I just installed for powering the router. 25 amp relay and DC 3-32V control. Connected to the coolant contact and activated/deactivated with the M8/M9 commands. Works great.

1 Like

Thanks for all the advice. I upped the gauge wiring from the controller and the iot. I also moved the iot next to the controller to shorten the wire run. That actually corrected the problem. There must have been enough draw between the 2 to create the issue. I appreciate all your help