Is GSender a decent program?


I’m not trying to be a jerk by asking this question but I am having so many issues with my CNC. Full disclosure, I am very new to this. But simple things like finishing the the first of three carves with different bits, I go to move my router around and see that GSender says not connected. This happens a lot. I haven’t moved anything that would cause this to occur. Here is what I question:

-Is Sienci sending out bad computer to control panel cables?
-Is GSender too buggy/not a vetted piece of software?
-Is my controller garbage?

As someone who is pretty new, this seems like the one area that should run smoothly. I load up a file and run it. Why is it always disconnecting? Then what is more frustrating, I reconnect the router, the tab at the upper left of my screen says it is connected, but the tab in the upper right of the visulaizer says disconnected and I cannot move my router.

I’m struggling with end grain inlay simply because I cannot keep a zero point.

I am extremely frustrated with this so I apologize if it sounds like I’m whining but I’ve invested a lot of time and money and would like to start seeing some results!

Any help would be appreciated!

Thank you,

Now I finally got it to reconnect after restarting my laptop. I had to run the homing cycle. When it got to the home position, it continued to try to travel and sat their and roached the motors until I killed the power.

I had another common issue come up while probing earlier, I tap the z- to move the bit down a little ways so it will lessen probing travel and it just drives the bit into the auto probe. I had normal speed with .02 or whatever the default travel is.

I just don’t get this.

@Cropduster16 What make and model is your CNC?

Longmill mk2 48 x 30

Right now I cant even put power to the machine because the carriage is at its max travel and the motors are just grinding.

What Version of gSender are you using. I am still running V 1.2.1 on a home built unit with an Arduino based controller and gSender runs like a dream once I got all the settings spot on.

I’ve had no issues with gSender. Previously I was using UGS and it tended to be a bit glitchy, though, it could also have been the machine I ran it on.

If you can’t run your machine because you’re at max travel, manually back it off by turning your lead screws by hand.

If you’re having connection problems, I would start with a better USB cable and try individual ferrites on your cables to make sure you’re not dealing with false triggers from bleed over. Also, ground any dust collection from the dust boot back. That’s a big issue with connectivity loss.

1 Like

@Cropduster16 Hello! While I’m not sure what type of laptop you are using, I’m using an old MacBook Pro from 2011. I found one of my usb ports was sketchy, meaning wiggle it for connection. I switched to the other port and my problem went away. I too am new, and had some issues along the way. Step back, take a deep breath and put in a support ticket with the good folks at Sienci. They WILL resolve your issue. What does suck is this happens on weekends, I get that! Let us all know how you fare. It maybe me that has the same issue next time. The other advice provided is spot on however.

I appreciate all the feedback…

The gsender version I am using is 1.2.2. Whe I submit a support ticket, I will enquire whether this is considered a stable version. I used all the settings Sienci described in their latest video for setting up the sensors. I really want the sensors so I can create repeatable points and hopefully have a level of consistency.

The unit finally stopped trying to fire the motors when I put power back to it this morning. I manually moved the carriage away from the home setting and was able to get it to home. Unfortunately, my pre determined zero for the workspace I was using did not go back to the same spot so another inlay ruined.

The cable I am currently using does have individual ferrites on each end. The laptop I’m using is fairly new and the (2) USB ports get no use other than plugging in the controller when I bring it downstairs. This is a company computer and a pretty decent one at that (don’t let them know I am using it for woodworking too).

So I took the grounding seriously, as being a master electrician I know stray voltages can mess with things, or so I’ve been told. If this is a known issue, I am a little disappointed that Sienci didn’t use shielded cables for cabling. Also, there is no ground point on the controller for stray voltage bleed off. So I grabbed some #12 I stripped for my main dust collection and put 3 lugs on my machine - one on the carriage, one on the x axis and one on the y axis. I took it straight back to metal conduit I ran to feed my shop machines which ultimately has direct system grounding. Not sure if I can post pictures on this forum.

I did step back and took a break about two weeks ago when I went on vacation. It was hard to come down here and see I left the messed up piece still clamped up. Lets see if the grounding modifications will have any affect.

I will submit a support ticket tomorrow morning. Thanks again for the feedback and if you think of anything else, please share!

Thank you,

1 Like