Issues with Homing

Hello all! Received my SLB today and got it setup. This thing moves the axis’ FAST! Directions are correct and everything is smooth except homing. Homing z-axis is flawless and very quick, homing X&Y moves quickly but overshoots the inductive pickups and then shows “disconnected”. Homing seek rate is 5000mm/ min. Set it to 4000mm/min and no change. (Slower but still overshoots.) If all axis’ are close to home (within an inch) all axis’ home properly. Any ideas?

1 Like

I changed the seek rate to 3000mm/min and it doesn’t disconnect now. Changed it to 4000mm / min and it disconnects after hitting the limit for y axis repeatedly, sometimes does it on the x axis as well once limit is triggered. I also tried homing Z, then X, then Y instead of Z then XY together. (Didn’t know if the combined amperage of the steppers with Y and X stopping and then ramping off home position would cause the disconnect like a “brown out”. That change still led to disconnects on X or Y limits even when artificially triggered with a wrench). The odd thing is there aren’t any errors. There are no errors or warning messages, just disconnects. If I reconnect and run a homing sequence (while all the axis’ are near their respective limit switches) it homes and moves fine. I am perfectly fine leaving the seek speed at 3000 mm/min yet the disconnection makes me nervous about running any projects at higher speeds (which was the entire purpose for this board for me). Any insight would be fantastic. Thanks!

First of all welcome to the forum @Benjaminjaquith! It is a great forum with good advice. I just got notified that my SLB has shipped today. I am just looking around here to see other’s experiences with installing the SLB. I am confident that the excellent folks at Sienci will help you! Let us know your solution.
Jake

1 Like

Very odd Ben, I hadn’t seen this ever come up during testing. Is your setup fairly standard or are you using an altered LongMill or 3rd party switches? I’d be interested to delve further into the cause since a silent failure is surely concerning, though I feel like it shouldn’t impact the confidence in other aspects of the board operation

Everything is from Sienci Labs. Didn’t have an issue with the original longboard. I reseated all the motor connections, reseated the limit switches, double checked power in plug to make sure it was seated properly. One thing left is to monitor 24v in while homing @ the higher speeds and see if the supply voltage dips too much. Here’s a video of it happening.

I’ve milled a few projects and haven’t had an issue.

1 Like

Ok thanks for the video I’ll check it out. Glad it’s been working well for you so far Ben!

EDIT: I’ll also add in here an issue Jim reported that sounds quite similar, though I’m not sure on the hardware he has either. Seems there was a fix by increasing debounce time. This might be a case of the newer homing settings being a bit more on the aggressive side though still need more investigation to verify if true. Ben you might be able to try the fix of increasing debounce or pulloff distance as well so you can keep the higher homing speed and see what that does for you

Off topic but I love this machine you guys created. I follow the videos and creative posts. Love this community and the minds behind it all! Very welcoming and packed full of information. I appreciate the time spent to help EVERYONE learn this hobby bofh by constantly improving the capabilities of the hardware and the countless hours documenting and assisting. It has made this fun for me and I look forward to every project I run. Thank you everyone!

2 Likes

@Benjaminjaquith Ben, you help make this forum and Sienci Labs so special. The positive attitude, upbeat posts, even when having difficulty, is what sets this forum and this company apart from everyone else’s product. I came here almost 2 years ago knowing nothing about CNC or design. These folks held my hand and helped me be successful with my LongMill. I learn something new every time I make a project. It keeps my brain active and working. I love this hobby and hopefully soon a real live business. We are glad you are here!

1 Like

I did forget to mention I moved the pull off distance from 1.5mm to 3 and there wasn’t a change. I will adjust the debounce setting according to the link you posted and report back. Thank you!

1 Like

I changed the debounce setting from 25ms to 250ms and it still disconnects when homing X @ inductive sensor or Y @ inductive sensor. Haven’t had much time this weekend to dig into it deeper. Will check power supply voltages @ the Super Longboard and see if there is a significant dip. All the stepper current values match so it’s not like one is an outlier. Just really odd that there’s no warning message, just disconnects. Will keep messing with it. Thank you all for your replies!

1 Like

Sounds good Ben, let us know how the testing goes

@StephenCampbell was doing some testing and said he finally recreated but I’m out sick today so will check in at the office tomorrow and see what we’re seeing on our end and what a good fix might be.

1 Like

Just installed my new slb and doing the same thing turns off when i home

I’m also encountering the same issue, but it seems to be isolated to just the Y (I separated out the axis order). I’ll run through the suggested tweaks above and report back.

What ended up working for me was setting $26 to 250ms, and homing Z first, Y second, and then X third. So far dozens of tests with X and Y at the same or different distances haven’t caused a disconnect so I’ll leave it there unless someone needs more data from the failing tests.

My failing test results were not consistent, but I’ll list them out in case it helps narrow down a bug. Both of these tests were with homing Z first and then X & Y second:

  • I was able to leave $26 at 25ms for most of the testing, as long as my Y axis hit home a few seconds before X. If X was already home (and triggering the switch), it would disconnect when Y hit home.

  • Setting $26 at 250ms made things a lot more stable. X could be at home and when Y got home, things were ok most of the time. However if I hit Home when X and Y were the same distance, ~25% of the time it would disconnect. I ended up zeroing out X and Y 200mm away and doing many cycles of Homing, then going to 0,0, then Homing again.

Just installed my SLB yesterday and ran into 2 problems: the first seems to be a bad e-stop switch - different discussion; the second is the homing with limit switches and Ethernet disconnects.

Saw the discussion about changing values in $25, $26 or $27. After some experimentation playing with the debounce setting ($26) where I increased it to 1000ms and it worked without a disconnect. Then I played the game of divide and conquer, so at 500ms- :white_check_mark:; 250ms :negative_squared_cross_mark:; 375ms :white_check_mark:; 333ms :white_check_mark:; 300ms :white_check_mark:; 275ms :negative_squared_cross_mark:; 287ms :white_check_mark:; 281ms :white_check_mark:; 278 :negative_squared_cross_mark:; 280ms :negative_squared_cross_mark:. So 281 ms works - your mileage may vary.

3 Likes

I too have been trying different values for $24 through $27. The most reliable for reducing disconnects on my MK1 12x30 SLB is:

Feel free to fine tune your own machine and report back which homing settings/speeds work best for your setup.

Cheers,
Stephen

Having the same issue. Set $26 Value to 300 and it solved the issue. Thanks @grubbertire

1 Like

After continuous testing, we’ve found that updating the SLB defaults to:

  • $24 = 150mm/min
  • $25 = 4300mm/min
  • $26 = 25ms
  • $27 = 1.5mm

Has resolved homing disconnections and in comparison to the prior settings this will only making the average homing speed about 0.5seconds slower than the prior default settings. We’ll look to send out a new firmware update once we’re confident in the release that will have these speeds as the new default, but in the meantime anyone who having these issues can use these new values and shouldn’t see the problem again afterwards :slight_smile: