Job start by raising z till it hits limit

Hello, I am new to gSender switching from Easel and am using an x-carve CNC. I am using Ventric as my CAD software.

When I load some gcode the render looks correct. But when I try to run it, the Z is raise till it hits the limit switch and errors. I have tried dropping the z to give it more space.

I assume I have something miss configured. However I can jog the machine around, homing works correctly, and sending to the corners works correctly.

I cant attach my g-code file but here is the start.


Are you using metric or imperial? and are you using the correct post processor? (mm/in)

If you are using grbl in instead of grbl mm then your router might be trying to move 20.320 inches in your Z. G21 is mm correct?

Edit: I really should add that I might not know what I’m talking about. Trying to get involved helps me learn, so…

The G21 sets the units to mm so I don’t think that’s it.


He has a G21 which sets the unit mode to metric (mm), but you still need at least 20mm in retraction room above Z-zero.


I just noticed that and started editing my post

Shoot a screen shot of your Vectric “Material Setup”. Your settings for Rapid Z Gaps and Home / Start Position are important.

I recall that there is an additional ‘Safety Clearance’ setting in gSender. If set to zero, it does nothing, otherwise it makes the machine retract this amount before starting and upon finishing the gcode.

Might be worth checking what this is set to before investigating other possible causes.

Thanks for the replies. The responses gave me plenty to check.

I found the issue, in the end was a pretty simple mistake on my part.

I was testing the movements without the bit in. I homed the machine, but didn’t zero it. I only have Z axes zero so didn’t make sense to do that without the bit in.

Setting zero gave the expected results.

Thanks again for the pointers much appreciated.


@SnackPanda Since you have resolved your problem, I am closing this topic. Have fun.