Keep having X-axis wander in positive direction mid-cut

First few projects with the long mill went great. A few nights ago I was cutting a more complex (multiple bit change) project and something went wrong after the last changed. It started running fine, but then cut further in the X-axis (positive direction) than it should (ruining the project in the process).

I chalked this up as my reseting the work origin incorrectly during the tool change.

Today I started cutting another project (a sign). First toolpath ran fine (surfacing bit). Second tool path was a pocket with a 1/8th end mill. This was going to take three passes to get to depth. First pass seems to have finished fine. Second pass was in progress when I walked into the garage. I was zooming into the visualizer and then heard the sound of the router change as if it was cutting harder all of a sudden. I look up and sure enough it’s cutting out at the end of the board when UGS thinks it’s in the middle. Looks like it was about a 6 inch offset in the positive X direction. After my initial frustration :slight_smile: I hit return to 0 and sure enough it wasn’t at the corner of the board where it was before.

Jogging and rapids seem fine - and it was cutting fine for about an hour before this occured.

What would be causing the X axis to run too far forward in the middle of a cut?

Using Carbide Create for CAM and UGS for interface.

@shaun_adam Welcome, Shaun. I assume that you do not change X0Y0 between bit changes, yes? Z0 needs to change to account for the different bit lengths, but X0Y0 should never change. Confirm that, please, and we can go from there.

That’s correct. I follow this sequence for a bit change:

  1. Hit return to zero button in UGS
  2. Jog z-axis up so that I can more easily change the bit
  3. Change bit
  4. Jog Z-axis so that new bit is at surface
  5. Hit reset zero button

I just made this sequence up (I’m very new to CNC), but it seemed to work fine on my first few projects.

I think it’s important to note that today’s issue did not involve a tool change. The toolpath had been running for about 45 minutes and had finished the first ‘layer’ of the cut (out of 3 planned). It was just a couple minutes into the second layer and then started cutting way too far out. Everything was fine up until then. I wasn’t staring at the machine when it happened so I can’t say exactly what happened as it took off. I noticed when the sound of the cut changed (it was cutting twice as deep as it should have been as it was off the design).

It’s also worth noting that when I hit return to zero to see where it’d land it was only off in the X direction (it was still at the surface of the board (Z) and right at the edge closest to me (Y).

Hi Shaun,

Do you set $1=255? This keeps the stepper motors energized, which prevents you from accidentally moving bumping any axis. If the motors are not energized, you can easily any axis by hand.

Also, when using the wrenches, keep the handles close together and squeeze together or pull apart. Don’t put them on opposite sides and push or pull. This prevents putting pressure in a direction that could change your position.

Additionally, you don’t have to return to zero for a bit change. I do recommend moving off your work piece though in case your bit slips out, you don’t want it to mark your project.

My workflow is:

  1. Raise the Z and move away from the workpiece.
  2. Change bit.
  3. Find a nice flat spot, anywhere level on your stock and set the new Z height by eye/feel or using a touchplate.
  4. Set Z zero. Return to zero just to make sure.
  5. Run next toolpath.

I also like raising the Z before any moves, just in case it drags across my workpiece.

Thanks for the help with tool changes! I’ll be sure to give that a try. What do I click in UGS to ONLY reset Z? Is it the Zo button?

The motors seem to stay engaged, I’ve never felt them move at all whle changing. My real issue here is the random wondering while it’s operating. It suddenly ended up about 6" too far. This is with me not changing anything at all - it was just cutting fine and then it wasn’t.

I uploaded a couple pictures. The one with the router to the right is where it was when I hit stop. In UGS it thought it was cutting in the center of the piece. The one with the router to left is where it returned to when I hit ‘Return to Zero’. It should have went to the left corner of the board.

Yep, I usually set the height I want and then click the Z0 button where it shows the current coordinates if I am not using the touchplate.

Do you hear the X-axis motor running, but the axis not moving?

If you can hear the stepper motor moving then maybe it is the coupler between the motor shaft and the lead screw that has come loose.

Not a bad idea at this point to go around and re-tighten all of the bolts anyway.

I’ll check all the bolts in the morning. Good idea.

It was jogging fine afterwards but I suppose it could be intermittent.

It could be the loose coupling on your x drive, I guess.

I had a look at all the connections and everything seemed fine. I swapped out UGS for cncJS and tried cutting again - after about 4 hours I had a sign. No issues at all. Neither this design or the previous where I had problems were overly complex, but none the less that seems to have solved my issue.

If someone else stumbles upon this I used the desktop app for cncJS. I’m running Windows 10 on an i5 (duo core 2.3 GHz and 4 GB of RAM). It never seemed sluggish with UGS, but in my opinion cncJS is much more responsive and the buttons easier to understand.

Thanks to all for your help!

1 Like

interesting because i just posted a question about the OneMill were all is fine then 2/3rds through the jon it offsets the y axis by a few mill. I’m also using UGS 2.0.7 on windows 10, so i may also try cncJS

Ya, I’d give it a go. Having used both now I’d give cncJS an edge over UGS in user experience and stability. Feels like a more up to date platform. I’m also not a huge fan of Java though, so perhaps I’m biased. :slight_smile:

Thanks for posting this. I had the same thing happen on a long relief carve. I’m a noob and still learning, thought I must have done something wrong. I’ll be giving cncjs a go, ugs just feels clunky to me after coming from lightburn for laser work.

Hey so this went away. I don’t think changin to cncjs fixed it, but like shaun_adam I’ll stick with cncjs as it just feels a better product. I checked things other folk said like, not running the gcode from a usb stick, turning off all pwoer saving a sleeping. I personally think it was my screen off kicking in.