Keyboard shortcut glitch

gSender 1.1.7 64 bit
Windows 10 64 bit

This bug may have been present in previous versions.

I have jogging and zeroing keyboard shortcuts enabled. I use a numeric keypad to send the keystrokes to gSender. However, this issue is present when using the same shortcuts on a regular keyboard.

Here is the issue:

When I open gSender, it opens in the default workspace = G54. The keyboard and numeric keypad work properly. If I change to another workspace, say G55, they do not work. However, if I click on a GUI jog button for example, the keyboard and numeric keypad work properly again. If I return to G54, the same problem exists. I need to do something in the GUI to enable the shortcuts.

1 Like

Thanks for the detailed report. It looks like the workspace dropdown isn’t giving up focus after selecting a new workspace - should be an easy fix.


I have a similar issue and it may be related. When I change the value for a jog, I must first click on the GUI for any of the 3 jogs before the keyboard shortcuts will work. Not a major problem, just annoying.

We should have fixes for both of these issues in the next release of Main/Edge.