Keyboard shortcuts don't seem to trigger macros

Using 1.0.6 (same in 1.0.5) I have some macros defined that move the router by specific amounts. If I click on the macro it works as expected. As a test I defined keyboard shortcuts for several of them (like ctl-@). Clicking the key combination does nothing. Am I doing something wrong? Is this a bug?

I just purchased a programmable keyboard so I can trigger macros from it.

Thanks in advance,
Frank Alviani

@falviani Long time, no post, Frank. Welcome back.

I use keyboard shortcuts for macros without an issue.

In gS, settings, shortcuts. Scroll down until you see the blue macros entries. Your macros should be listed by name in the left hand column. Click on the + symbol. This will open a dialog box that allows you to set the key combination you want for the selected macro. Click on the “save changes” button. Then move the slider to the right, which will change it from grey to blue.

Does that work?

Afraid not. However, I didn’t have a gcode file loaded. Could that be it?

@falviani No, when I just went through the steps to write my previous reply, I didn’t have a filed loaded,either. Frank.

To be clear, you see all the things that I see and you did all the steps that I did and nothing happens??

Can you post a screen cap of the shortcut screen showing your macro shortcuts?

Can you try with a different keyboard? Just an ordinary keyboard.

I did everything exactly the same. I was using the normal keyboard on the machine, NOT the programmable one.
Clicking on the macro in the macro table to run it works as expected.
Typing on the programmable keyboard into notepad produces the expected keystrokes.
Annoying as heck.
Thanks in advance for your time,

@falviani Here is what I tried just now, Frank.

I added your macro to my list.

It ran if I clicked on the macro

I set the shortcut to crtl-shift-2, which shows as ctrl-@, just as your does

I pressed ctrl-shift-2 and it did not run.

I changed the shortcut to ctrl-2 (no shift). It ran

I changed the shortcut to ctrl-shift-a. It ran.

I changed it again to ctrl-shift-5, which shows as ctrl-%. It did not run.

I changed it to ctrl-5 (no shift). It ran.

The common thing about the ones that do not work is that the character added to the ctrl press is a special character - shift plus a digit. Using just ctrl and any key works. Using ctrl+shift and any of the letter keys work.

For all I know, it’s a grbl thing and cannot be fixed. The gSender team at Sienci will see this, no doubt and may be able to add to my gibberish.

1 Like

Creating shortcuts without the special characters (capital number keys) worked fine. I’ve reported this to Sienci. Thanks for your acute observations.


@falviani Although not a solution, at least you can work around this for now, Frank.

As we’ve taken this as far as we can within the constraints of gSender, I’ll close the topic.