Laser Not Functioning in Gsender

Hi everyone,

Long story short; I’ve had my laser from Sienci sitting in a box for about a year now unassembled. Yesterday I finally got around to putting it all together. I used Lightburn to create a very simple project (square coaster with words on it, I was trying to do FILL on the letters and CUT on the square on 1/4" ply) to give it a test.

When I connect the machine to my laptop the laser flashes and the machine comes to life as it usually would when the router is the primary tool. However, the “laser On” button doesn’t do anything so I’m unable to focus the laser. It changes in the software to say “LASER ACTIVE” but the laser itself doesn’t actually turn on. I’ve checked all the settings, made the $30 firmware adjustments and have checked the connections. No go.

So just to see what would happen I clicked “run” and the laser did indeed fire up (unfocused of course). It then proceeded to run the shape of the letter but it didn’t ever shut off. So it basically just burned big black rectangles without ever pausing. Just continuous run and burn.

Can anybody help me work through this? I’ve googled but can’t seem to find anybody else with this problem.

Thanks kindly,

What is $32 set to? It should be 1 or true when using the laser. $30 should be set to the same value as S-Max in LightBurn. $30 = 1000 and $31 = 0 gives a range of 1000 and makes the math easier if you have to look at the code for some reason.

I’m also not sure about your workflow/setup. Are you not able to control the machine with LB. Usually if I use LB to make the code, I run it from there and eliminate one tool from the software stack.

There is no real problem using LB to make the code and gSender to send it. You just need to make sure the settings are compatible in each step in the chain. If mixing programs it’s useful to enter $$ in the console to check the settings to make sure $30, $31 and $32 are correct before starting the program.

@Abradel You have posted this in the gSender/Question category but it is not clear that you are using gSender. You mention that you created the project in Lightburn. Did you then export the gcode and open it in gSender?

Yes sorry. I make the file in lightburn then export the gcode to gsender which isn’t able to control my laser properly.

I’m brand new to Lightburn. I’ll try running the file right from there and see if I have better luck.

Settings all seem to be right, no idea why gsender can’t run the laser

@Abradel One simple thing to verify is your Smax setting in LB. It must be the same as the $30 setting in gSender.

Tried that and no go. Gsender just can’t seem to control the laser

@Abradel Post back when you have tested it in Lightburn, please. Don’t export the gcode. Just create a square or something simple in LB, and burn it directly from there. If that does not work, then you will know that your issue is not gSender-related.

Well it looks like I’m in business! (sort of). I checked every connection again then I flashed the firmware back to full default/factory settings and started from step one (again). This time, it worked!

Now my only issue is the engraving is working great, but it doesn’t seem to be cutting. But I’m sure that’s just a power setting I need to sort out (learning curve).

Thank you all for your help.

@Abradel It’s good that you are up and running. IMHO, though, you will not get any joy trying to cut 1/4" material with a 7.5w diode laser.

I will close this topic now, since you have resolved the issue.