Laser runs but doesn't actually burn anything

I have gone through the set up instructions and watched the assembly video provided @ Assembly Video Guide - LongMill CNC

I downloaded LightBurn and created my first file to run with the new laser just shipped from Longmill. However, when the job runs, the laser fires on and off but it doesn’t actually burn the material.

The only time the laser burns is when the Test Laser setting is on when trying to zero the laser. At 2% it starts to burn the wood, but the actual job doesn’t burn at all.

Any ideas would be greatly appreciated :slight_smile:

This is my gCode file:
LB_DISKS_BeaSophia.lbrn (497.1 KB)

This is my gCode file: (895.7 KB)

@BrandonB Welcome back, Brandon. A quick look at your LB files shows that you have the feed rate set to 1181 in/min. Unless you have changed the default settings for your controller, the max speed in x and y for the Mill is about 157 in/min. Even at the default max speed, I would suggest that you are likely feeding too quickly for the laser to be effective. In Ikenna’s video, he sets LB to 60 in/min or just over one third of your setting.

Hello @gwilki,

Thank you for your quick response. I appreciate the information with the speeds of the laser. That is useful.

I changed my speed to 25.4 like Ikenna’s video suggests with the G2 laser and the same thing seems to e happening. The laser turns on for the job but doesn’t burn at all :frowning:

Where would I set the speeds for the controller? I wasn’t sure if there was somewhere to set specific settings in gSender.

In LB I used the auto setup to find my laser. So not sure if there is any extra set up there as well.

Sorry for all of the questions. This is my first laser and I am really excited to get started.

This is my updated LB file:
LB_DISKS_BeaSophia.lbrn (497.1 KB)

Thanks again

Couple of thoughts:

Confirm the “S” setting in light burn matches the $30 eprom in gsender.

Check dip switch make sure your not on lowest setting. Try 4 or 5 position.

Last resort turn off the air assist in light burn cuts/layers screen. It puts M8 commands in the code which gave me fits. I didn’t have the same issues but the machine behaved very oddly.

@BrandonB Are you using LB to talk to the Mill/laser or are you exporting gcode from LB and using gSender?

I am having this exact same issue. Everything works fine right up until the actual burning part.

Hello @CraigN ,

Thank you for your response.

My S setting in LB is set to 255. I have been reading around and wasn’t sure if that corresponds to $30=1000 or if it should be the same $30=255?

I have my dip switch set to 4.

I will try with the Air Assist turned off in the file.

Thank you

I am using the gcode generated from LB and running it in gSender.


I believe the “S” value in light burn should be the same as $30 in gsender, wether 255 or 1000 as long as they are the same. I haven’t ran mine differently, I would assume it would only run at 22.5% max power with the configuration of 225 in light burn and 1000 in gsender.

@gwilki I must be the only one with the M8 command problem??

1 Like

I made a typo, meant 255 and 25.5% above.

1 Like

Thank you all for your assistance. I believe my problem was that the S setting did not match the $30 setting. Once I corrected that the laser started to burn the product. Now I get to have fun figuring out the best settings for my material.

Thanks again @gwilki @CraigN

@wilddog58 I would suggest checking the s setting in LB and the $30 in gsender. It solved my issues.

I’ve tried the lightburn to gsender method with no luck. so i’m just using lightburn instead. dipswitch is set to 4. I have the s value set to 255 plus the 1500 mm per minute speed. i focus the g7 lens (lens is only in a thread or 2 with the g7)
I then run the project… I have to dial down from 1500 to at least 600 per minute just to get a slight burn. This can’t be right. . my test project is just some very simple text i created in lightburn. anyway, these settings seam simple enough and i should be getting something happening. i do believe they sent me a faulty laser. frustrating to say the least.

@wilddog58 What do you have the power % set to in LB? Did you set $30=255?

1 Like

I’d be curious about you cut settings in LB. seems most of the time (not always) it’s something simple I’ve looked over when I have an issue, so please don’t be offended if these seem like silly questions.

I assume you focused the laser as shown in the Sienci video. Which would be set the laser height above the work piece with the G7 gage then use the focus ring to find optimal beam size. That should be the Z zero height. For future jobs you only need to adjust Z to the gage and make sure to set zero.

What are the cut setting in LB. you mentioned speed and dip switch position on driver but not the power % for you project in LB.

Finally, what type of material are you trying to cut? I think the darker and harder the slower it would need to go. For reference I do a lot of baltic and lighter colored woods and did my first project with slate today, all of there were ran in the 100+ inches/min (2540 mm) and 50-70% power range at 4 amps.

1 Like

Howdy, gwilki. I should have checked the gcode in the first place. i was going off the value set to 255 in the device settings in lightburn. in the console $30=30000 was what was entered in there. anyway, i changed the value to 255 and walla i now have a burning laser. Thanks for the help. i appreciate it.

1 Like