Limit switch updates

I just purchased the new limit switch upgrade (hope receiving soon.

So I try to enable the homing option in gsender ($22) and all other option who are enable when I see the video. And after saving it I never see the homing button in the upper right corner of the “location” button. And is it normal each time I close and reopen gsender, I must re-enable each homing option?

Is it just normal because I didn’t already install switches?

Changing the $22 setting works for me to enable and disable homing. How are you changing the setting?

No, this is stored on the controller, not in gSender.

gSender has no way to no if you have installed switches or not.

EDIT: I was able to replicate what you’re seeing if you changed the setting under the “Firmware” settings. Just send $22=1 through the console…that works as expected.


I believe $21 needs to be enabled.

it will pop an error saying you need to home, and then when you go to home, its going to start its cycle.

without the switches installed, your never going to be able to trigger it, so its going to ram into the ENDS.

so WAIT to enable this, this config expects everything to be installed and configured.

$21 is for hard limits.
Not needed for homing.

Thanks. I was just curious to see how it works before installing switches.

1 Like

I think it’s an occasional bug that we’re still trying to figure out the cause of. Normally, once the change is made to enable Homing then from that point on you shouldn’t have to worry about anything else after that