Long mill CNC 30x48 loses home position

I have a lingmill CNC 30x48 that seems to keep losing the home location while cutting for example it cut the project great upto the last cut of the first layer which is the tracing/Triming cut when this cut starts its about 2mm off and then when you E stop it and send it back to Zero/start/hold position its off by almost 20mm and if you send it back to home it doesnt go all the way home, this is better than it was.

I had separated my router power wire from all signal wires and put grounding/bonding wires on every axis grounded to power with surg protected plugs i re squared it and homed everything in before going back to defaults which didnt help, i need help and am completely out of ideas and cant fond any information on this issue anywhere.

I could be wrong (would not be the first time), but I think when you hit the E-stop, you need to reset everything.

1 Like

@ozguzzi is right. If you e stop the machine does stop, but gsender cant dectect it and still keeps thinking its cutting.

Thats why after e stop you still have to stop program.

You will have to rehome or zero so that gsender knows where the machines position is.

1 Like

Ok, however its losing home regardless of e stop though that doesnt help any when i push it, it also doesnt know where its supposed to be at about 90% of the way through a cut order and i have to rehome it every time but when i do that it errors out before getting to it’s rehoming position because it doesn’t know where it is.

sounds more mechanical.
Did you check estep calibration?
are you using sensors?
backlash nuts should be loose on a new machine. Are they too tight?
X and Y off or just one?

encase software related
Is this a multi file process your cutting, or just one file?
Did you merge files?

If you run it in air (don’t cut any material), does it still happen?

Im looking into the possibility of a corrupt file now, I did 3 test peojects yesterday and it cut correctly all day long, and it only did it on X and it worked as designed upto the vary last pass, and yes I had reset all the lash nuts 3 times prior to this forum and it still did it, though I also noticed the machine isnt as violent as it was prior to bonding the hole system to grounds. It didnt whine or scream at all yesterday and the auto zero touch plate has worked 90% of the time and hasnt broke a bit since the grounds either.

I am still losing position on X axis only; it gravitates to the right in all file types but most noticeably on 3D files, I’ve reset the machine over and over again, grounded every gantry, separated power from signal wires, gone through the entire machine set up over and over and calibrated it over and over and it still is off to the right on the X axis by 1 to 2 inches every single time.

A common issue is that the coupler for the X axis on the motor side isn’t being tightened enough, causing it to slip. Have you tried double checking your coupler isn’t slipping?


I’ll check it tonight. Thanks