Long Mill Stopping in middle of job

@Jonl if you have the limit sensors and the errors are all hard limit errors then use Gsender to disable hard limits in the EEPROM in the controller. Hard limits are necessary.

1 Like

This is only happening when the dust collection is hooked to the adaptor. been trying different things . Could it be building up static electricity. Ran three jobs with dust collection running but not on adaptor, run without problem. But this as never happened before yesterday

1 Like

@Jonl, could be due to changes in humidity, although the onset was pretty abrupt. I know here in MN in the winter the furnace runs and dries out the air and static gets worse.


Continuing the discussion from Long Mill Stopping in middle of job:

The hose for the dust collection has to be the problem, run 5 more jobs with out hose on router no stopping. Run two with hose ,stop in middle of second run. Will try some sort of ground for hose. Have two jobs for tomorrow. Will let everybody what happens.

@Jonl I had the same problems over too long before I grounded everything that I could. Since then, I’ve had no freezes. I’m sure that you will find the same.

1 Like

So could static build up some how cause the router to plunge as far down as it can and stop moving?

1 Like

@Swinly I’ve not had that happen, Lonnie, but I think anything is possible when static rears its ugly head. :grinning:

1 Like

I’ve noticed that whenever I touch the mill during operation with the dust collector hose attached and vacuuming, that I get a static shock. I’m going to be on the watch to see if a similar thing happens to me, too.

Lonnie, how did you go about grounding everything? And did you run a bare wire around the dust collector hose and ground it as well?

Kingston, ON, Canada

I haven’t grounded anything yet. I just started reading up on it.

There exist several threads about this topic, e.g. this on

I can say (keep fingers crossed) that I haven’t had any problems with statics yet, but I did ground my router when assembling my LM (had to replace the cable of my router anyway because it was too short for the drag chain).


Well about 16 hours and many pieces of plywood I may have a solution. I ran with everything hooked up and it stopped 2 times out of 4 tries, all with different error. I than ran with everything hooked up but left router above wood, never could get it to stop. I than run about 30 minutes every thing on with dust boot not hooked up and cutting plywood .NO stopping.I than took a bare ground wire wrapped around flex hose from hose clamp next to dust boot to earth ground. The second run it didn’t stop but router plunged down though plywood and to e stop.I than ground router and metal boot that holds dust boot,but still stop 2-3 time in about 1 hour run. The last thing I run a bare cooper wire about 6" up the flex hose on inside and under hose clamp, Ran 3-4 jobs about 1 hour run time with no problems. Still dont feel warm and fussy that it is fixed.


I have the exact same issue; my MK-2 freezes soon after initiating a carve - either while travelling to the beginning of the carve or during it. The ONLY thing I have had success with is significantly slowing down the carve feed-rate to 20% or less. There also seems to be benefit keeping the X-Axis lead screw well lubricated.
I do not have this occur with all carves; just ones that I have repeated certain projects. That makes me think there is a possible software issue in either gSender or V-Carve Desktop. And yes, I have replaced my cable to a quality EMI shielded one. Finally, my dust collector is not the problem. I ruled that out by keeping it and any other electrically powered device turned off - and this problem still happens.

@Fredymac You mention that the freeze only occurs with certain files. Does it always occur with those files, or is it intermittent with those files, also?

Have you tried running the Vector checker in Vectric. I had a similar issue, but once I resolved all the overlaps etc that the checker highlighted, the job went through.

I believe that the problem is feed rate. Using gSender, if I stay below 2,000 mm/min, all is good. As I attempt to exceed this value, then the router will stop. X-Axis then needs to be re-zeroed but Y and Z seem to be retained, - and I have to re-start the toolpath. In a way, this is surprising because where I may want a low stepover to achieve a very smooth finish, I would want to speed up the feed-rate. But this aggressive setting seems to come with a negative risk that may not seem worth the anticipated time savings.

1 Like

@Fredymac You could be onto something, Bill. However, since the Mill is capable of consistent and accurate 4000 mm/min moves, you may want to look at

  1. the tightness of your X delrin wheels

  2. the tightness of your anti-backlash nut

When this problem began, I looked into tightening them (they were sloppy). That did not help. One of the latest things I did was to disable limit switch activation - because I do not have any. This seems to have helped. I also have tried Candle (which I hate) and all of my TPs ran at normal feedrates. So back to the limit switch deactivation feature in gSender, all of my TPs that I had trouble running (and even running the Outline feature was freezing the travel) have for the last day of experimenting at full speed of 3500-4000 mm/min works fine. So we will see if that holds up and if disabling the limit switch feature was the root cause.

@Fredymac After you have had a chance to run more projects, Bill, I would appreciate if you would report back one last time.Assuming that you have found the solution, I will close the thread.

thank you

1 Like

After all is said and done (noted in my previous posts), I ran all of the toolpaths and Outlines in gSender that previously ‘froze’. I am not sure what the final fix was, but nothing froze after multiple attempts.

1 Like