Longboard Controller For Millright CNC

Hi All,
New to the forum, and I am hopin that someone can help with my problem. I recently purchased a Longboard Controller for my Millright Carve King CNC. When I was purchasing I was torn between the Science Labs and MIllright, but the deciding factor at the time was the Longmill was back ordered, and I was impatient. I wish now that I would have waited, but hindsight is 20/20.

Oh well, as I stated I purchased the Longboard controller as I have had 3 Arduino Uno and CNC shields fry on me, so I wanted something more robust, that was somewhat plug and play. I believe that I have set everything up correctly, I have changed my EPROMS to the settings that are outlined on the Millright website.

My issue is this, when I turn on power, I hear the knock as the motors become engaged…I try manually turning the motors and they wont move, so power is getting to all of my motors. As soon as I insert the USB cord, the power seems to go out of the CNC machine. I can manually turn all of the stepper motor quite easily. When I connect on the Open Builds Control, it gives me a Port to connect, it connect, but then when I try to jog the machine…nothing. No hum, no click, nothing. the motors can still be turned manually.

Any ideas as to why it would act like this?


Welcome @Gari!

I’m not sure if this matters but I don’t think I’ve ever connected the USB after powering on the machine. I always have it all connected first.

Other than that, did you have an E-Stop button to connect to the LongBoard?

And I hope you found the resource page for the LongBoard if needed.

Can you post your Grbl settings?
EEPROM is on the controller. Every controller has it’s own EEPROM, so unless you’re updating settings they can’t carry over from controller to controller.
I’d be concerned that you fried 3 CNC shields. That shouldn’t just happen. Are you confident everything is wired correctly?

Yes my controller came with the estop button. I also tried turning everything off, hooking up amd then turning on…same issue. I have found the link tha ks.

Hi yes i understand that EPROMs are on each controller. I updated the controller in the Open Builds Control program under GRBL setting tab.

I was also concerned with frying three boards…one was my own fault trying to adjust the VREF. The other two i believe were from using dull bits, my machine caught and dug in and crashed. I stopped it, jogged it, turned everything off and then it wouldnt load back up. Tried to redo Arduino, and nothing worked. So i assume it overheated and fried the board.

Here are my settings below. I dont have limit switches installed.


Per pic it shows firmware detected.

Change $2 and $4
As those settings would be specific to the controller electronics, not the machine.
Source for longboard settings here.

1 Like

Thanks so much Neil…that was the fix. Up and working now!!!

1 Like

@Gari Since @NeilFerreri has resolved your issue, Gari, I’ll close this topic.