Longboard failure?

I did a long carve yesterday - only my second time using the machine. Everything seemed fine.

This morning, I can’t get much from the machine at all. The LED on the longboard is flashing about once per second. If I connect UGS and try to jog, it jogs in tiny pulses in time with the LED.

That’s it. Nothing else. I’ve tried rebooting, unplugging, etc.

Edit - I should have been more specific - the machine is down and seems unusable, and I can’t find any trouble code info on the longboard. @Chris or @andy, is this a known issue with a known resolution?

Ok, I cleared the eeprom and reloaded the firmware. No change. I also note that the LEDs on all 4 drivers flash in time with the main one.

:confused: any ideas anyone?

Sounds like power switch problem. Search for power switch. There is a work around if you know how to solder. It bypasses the power switch so to use plug or unplug power cord. Should be a temporary fix until they can ship you a new controller.

I should be able to rule that out pretty quickly, thanks for the tip.

ok, soldering on the pcb is beyond me at the moment, especially while it’s still under warranty, but I did pop the hood and can confirm that jumpering the power switch produces the same results, no improvement.

I can also see that 3 of the drivers (X, Y1 and Z) have two blinking LEDs and Y2 only has 1.

Also after being plugged in for only 5 minutes, the heat sink on Y2 is quite warm while the others are cold.

Happy to report that the replacement controller shipped fast, arrived fast, and worked perfectly!