Longmill Dead....kinda

I was starting a contour this morning. The CNC moved wrong on its axis…so I hit the emergency stop. I have reset it. Nothing. I tried rebooting everything, tried using a different laptop…nothing with anything I tried. I can see the green light on the control board, and have tried several different outlets to see if there was an issue with the outlet.

I have gone through the troubleshooting on the resources page. No luck. Does anyone have any other suggestions?


Hey @SeanH sorry you are having problems. Does your LongMill show up as being connected in gsender? That would be a good start. Next, I’d check the usb cable. I had a usb port problem with mine, but I believe you switched laptops. Did your LongMill work before you hit the safety shut off? Let me know and if you figure it out, let all of us know. It could easily be me dead in the water next time.

Thanks for your thoughts here. I am dead. Gsender recognizes the system, just cant move anything.

@SeanH FWIW, I would bypass the emergency button if you are sure that it is in the on position.

How do you do that? I am not sure how.

@SeanH I would unplug the controller, then unplug the Oops button. Plug the controller back in and measure the voltage between the two pins on the control box. I believe that it should be 12v, but you can verify that on the specs page. If it is 12v, I would uplug the power supply and put a jumper on the two pins. Then I would power it up.

If you don’t have power between those two pins, you can report that to Sienci. If you do, and jumping them solves your problem, then you have a bad Oops button.

All that said, before I did anything, I would turn the Oops button on and off a few times to make sure it is not simply sticking open.

This may be something I will try if Sienci isn’t able to help me correct the problem. I am very reluctant to try something like a jumper.

The idea of the oops button sticking has crossed my mind. I have tried turning it on and off several times.

When you turn the button on and off does the light on the control board go on and off? The light on my control board is red but it goes on with the button out and off with the button in.

No red light at all.

@SeanH I’m sure that Sienci will get you fixed up. As I don’t have your model of controller, I don’t know why you have a green light and @_Michael has a red one - or even if that is relevant to your problem.

Please post back when you have resolved this so others can benefit from your experience.

1 Like

My thought was that if the light on the control board changed status with the OOPS button position then it would indicate that the switch was working.


I am sure they will get me taken care of.

Sorry if this seems to be a stupid question, but have to ask, worked many helpdesks.
Did you twist the Oops button to pop it back out?

Good question. I don’t think there is a stupid question when dealing with the general public.

I have checked this multiple times.


1 Like