Longmill line project

Hope everyone is fine.
Got my machine up and running on a raspberry pi4.
I downloaded the long mill line. The issue is that the router would not go into the wood to cut. It follows the pattern but will not go deeper on the z axis. Ive reset zero with no success. When the play button is pressed the router raises then drops down to the surface of the wood thereby not cutting.
What can I do?

@bubalarry I don’t know that the “longmill line” is. Can you explain, please.

What software are you using to generate your toolpaths and what software are you using to send them to the Long Mill?

The longmill line is a starter project that can be downloaded from the scienci site. I am using the ugs universal g code sender. The ugs platform is running with raspberry pi4.

@bubalarry Got it! Sorry about that. In your other post about upside down letters, you mention that it is from the starter projects page and I just went there and saw it.

Unfortunately I do not have a definitive solution to this problem or to your upside down cutting issue. I have no experience running ugs on a raspberry pi, but I would suggest that you start with the idea that may be the issue. I believe that Chris generated the toolpaths running Carbide Create on a windows based machine. You are taking those toolpaths and sending them to your Mill from a raspberry pi. I don’t think that it’s unlikely that something is being lost in the translation, so to speak.

I’ll copy this to your other post since others may have some ideas.

thanks for the reply. Ive posted a video on the facebook page.

@bubalarry I’ll let others here take over. I’m betting that Chris will know how to address this. I’m out of touch with the world - not having a facebook account - so I won’t be able to view the video. That said, you’ve explained your problems clearly. I’m interested to see how you solve it.

Hi everyone! I have just completed the build and ran the starter project. It looks like I am having the same issue where z axis not lowering to cut but appears to be following the x/y path just fine. Just wondering if this issue has been solved yet? From what I can see in the visualization in UGS, it looks like the starting point is at the bottom of the 5.12 mm depth of the project? Sorry, I’m very new to this and thanks for any assistance! Brad.

@badfenderaxe Welcome to the club, Brad. I don’t know if the original poster ever solved his problem, but we can work on yours anyway.

Before looked at the more complicated stuff, make sure that you Z axis is not bottoming out. If you have the router high up in the clamp, that could be the case.

If that’s not the issue, what CAM application are you using?

Post your gcode here.

Thank you for the welcome gwilki! I think I have things more under control now. I took some time, like I should have, and learned a bit more about gcode. The hardware is running great after the assembly. The documentation was outstanding! I modified the -Z values in the project file and was able to get the depth where I needed it. Thanks for taking some time to address my issue! I know I still have a long way to go. Brad.


@badfenderaxe You’re welcome, Brad. Like you, I have a long way to go. I think that I just started on the voyage sooner than you did. That’s all.

1 Like