Longmill not cutting to scale

I’m trying to cut a new top for my Festool MFT. The top has several rows of 20mm dog holes. I’ve created the file in vectric, and the holes are set to 20mm, but when I tr4y to cut the file, the holes are cutting to only 19.22mm. Any ideas why they aren’t cutting the full 20mm?

If the spacing is correct…

  1. Tool deflection most likely. Try running a final, full depth contour pass on the holes.
  2. Tool smaller than expected. Measure tool or compensate for undercut in your CAD/CAM.

Thank you for the suggestions. I’ll try running it again.

Well I ran the program again and it didn’t make a difference. It also isn’t cutting all the way through the MDF. Is there any kind of calibration that should be done to tell the machine that 1"=1" or 1mm=1mm? Or is that native to the stepper motors? Is it understood by the machine that a certain number of steps = a certain distance?

What did you change?

In my response above, I said that my suggestions assumed the machine is moving the correct distance. Are the holes the correct spacing?
I’m sorry if that wasn’t clear.
If you jog 20mm, does it move exactly 20mm?

Sorry, I wasn’t very clear either. I tested your first suggestion that maybe there was some deflection, so I ran the program again to see if the holes would open up. They did not. I haven’t tried jogging the machine yet, because I’m happy with the hole spacing, just not the sizing. I have 19.88mm bench dogs that should fit the 20mm holes. They do not. I put calipers to everything to make sure and the holes are undersized. So, not sure what to do next.

@cmorrowk Did you do as Neil advised and measure the end mill?

How are you making the holes?

You can resize your holes in your CAD.
You’re 4% small, so make the holes 20.8mm in your CAD.
Depending on your program, that may be tricky to keep the spacing correct.
You can also tell your CAM program that your endmill is 0.8mm smaller, so it will cut a bigger hole.

Using a .25" end mill to core it out.

@cmorrowk Have you measured the diameter of that end mill?

I just measured it. It was 0.248”

Have you tried the movement tuning tool in gsender in the “Calibrate Tab”?

I have not. I guess I will do that next.

That’ll affect the hole spacing as well.

@cmorrowk I was hoping to help you not have to recut the entire piece.

@cmorrowk Given all the foregoing, FWIW, I would run the calibrate tool to determine if your steps are off. I would enter the correct diameter of the bit you are using into your tool database. If you are using VCarve as your CAD/CAM program, try cutting the holes using a profile toolpath on the inside of the line, with a spiral ramp. Finally, ensure that you are using grbl mm as your post processor.

1 Like

So I’ve run the calibration and something’s not right. When I measure the distance x travels after it moves what it believes is 100mm, it will have actually moved, like 92. So I plug that number in and it does its calculation and updates the program. Then when I rerun the test, now it goes like 111 instead of 100. So I update again. This goes on and on, once too short, next too long. It never zeroes in on 100mm. I can manually set it to 201 in the settings and that is the closest I get.

I’ve also adjusted the diameter of the endmill, but that hasn’t helped with the hole size. I have to go into vcarve and change the hole diameter to 20.65 in order to get a tight but movable fit of a 19.88 bench dog.

Sounds like an issue i was having,
Look in your gSender firmware and make sure that your stepper motor travel (XYZ) are all set to defualt (200) mine were off slightly and sounds like what you’re going through. Apparently, this is caused when squaring XY .
Hope this helps, it can be frustrating.

Everything is set to 200. Always has been. But still not cutting appropriate sizes.

@cmorrowk Post your .crv file.