Machine moving after job complete

My longmill Mk2 is moving after every job I complete. It seems to move to the center on the y axis and then off to the left of zero several inches on the x axis.

Im not sure why, is there a setting in gsender that moves the spindle to a certain position after running a job? Maybe its the Gcode itself? It doesn’t show up in the preview in either fusion360 or gsender.

@Jonny_Five Does it to do this with every project? It will help if you would post at least one gcode file that shows this.

I don’t know what software you are using but in Carveco there is a setting for you to set your “Home.” After every job, it will return to those settings.


Yes, every Job. I mash the estop at the end of every job because I typically have a clamp sticking up right where the spindle moves. Messed up my dust collector the first time. Attached is a sample gcode. Im a bit of a noob here but i see that I can open the Gcode in notepad to see the actual commands.

After the last XYZ move, here are the list of commands… it must be fusion that is putting this in… I don’t want my machine to go to the origin, any idea on how to stop fusion from adding these gcodes in?

G28 G91 Z0
G28 G91 X0 Y0

If anyone could explain the differences between the “zero”, “home” and “origin” positions that would really help me.

Riley (57.1 KB)

@Jonny_Five I’ve never used Fusion, but there are users here who may be able to help with that. I believe that the issue is the G28 lines at the end of your gcode. You can test that my simply deleting them from a file and running it in air.

What post processor are you using in Fusion?

Do you have limit switches on your Mill?

Thanks Grant, ill try manually deleting those commands from the gcode and see what happens.

I am using grbl (ver 44053) as my post processor. I do not have limit switches on my mill.

Looks like that solved my problem. I deleted those lines of gcode and it didn’t move after completing the job. I see some post processor settings in fusion that I didn’t notice until now, I imagine I can figure it out now.

Thanks Grant, I appreciate the help.

@Jonny_Five You’re very welcome, Jonathan. As you have resolved your issue, I am marking this topic as resolved and closing it. If the problem recurs, don’t hesitate to open a new topic.