Machine won't jog

Hello guys.

Just got my longmill put together.
Made some changes to the assembly to have the wiring on the right side. Made all the necessary connections. Connect to UGS.
But I can’t get the machine to jog in the x or y axis.
The most I’m getting right now is the z axis traveling up and down about 1/2 inch when toggled.
Any suggestions.??

@3DDESIGNZ In UGS, change the step size to 10 or so and the feed rate to 1000. See if that makes a difference. The default feed rate for UGS is so small that it appears that the Mill is not moving.

You may want to try gsender, too. :grinning:


Same thing happened to me and what @gwilki said fixed it.

Got it.
Thanks for the fix.:+1::+1::+1:

1 Like

Hi. I was fighting the same thing. Kind of. Only 1 motor would try and jog. I did find any easy solution. I say easy but it took me 7 hours to figure it out, after trying other things. But now that I know it’s easy. The UGS program that they link to at version 2.07 bundled with java would not work. I had to install UGS classic. I also had to install java separate, but you may not have to do that.

After that it worked just fine.

Hope this works for you.

Thanks hobbyhands.
My fix was increasing the feed rate from 1 to 1000.

Even 1000 is not all that fast for jogging. :grinning: :grinning:

1 Like