Moters not going

I got it all put together but nothing happens. The board and the longboard are secure, I tried moving the unit to one side by manually spinning the screws and I can see a small light on the longboard light up while it is spinning (no idea what that means). When I use gSender to do anything it shows the spindle moving and says the job completed but I don’t see any movement, I also hear no motor sounds.

I used a multimeter and found something I think is strange. I have a green light on the arduino, I am getting some power changes on the J1 part of all motor boards but I am not seeing those changes on the outside port. I can provide any more information if needed.

Check the power cords going into the controller. The res light in the controller should always be on.

Where is the res light? I put a meter on it and I have power to the board but I see no lights come on.

I’m guessing that “res” is a typo for “red” as the S key is next the D key on QWERTY keyboards. Not sure if you have the new Super Long Board or the original but I have the original and it has a red light that is always on if the board has power and the E-Stop is not pushed in.

When you rotate a stepper motors output shaft that way the motor becomes a generator. In a general sense a generator is a motor run backwards. I’m sure it’s a little more nuanced than that as there are probably optimizations for one or the other but that is beyond my electrical knowledge.

I have a Prusa 3D printer and Prusa says not to move things manually if you can avoid it and do it slowly if you have to because it could produce enough current to damage the board. This is just an educated guess but I’m thinking this probably isn’t as much of an issue with the long mill because of screw drive vs belt drive. It’s much easier to move my printers bed fast than to move an axis on the mill.

Thanks, I didn’t know there was a long vs super long so I will take a look into that.

1 Like

I hear the motor start start when plugged directly onto the J2 pins, however, the motors do not actually spin. They simply click and I hear a high pitch hum like it is trying to move but can’t. I tried removing the motor so it was not connected to the drive screw and it still doesn’t spin…

I seem to have fixed it. Not sure how but each reassembly to the original configuration got me one step further. As a note you have to unlock the red stop button before anything works too.

I use the E-Stop as the machines normal off button. I’ve heard the motors humming after a while a couple of times when I forgot. Not sure what caused the motors to be energized but the GRBL firmware is always running if the control has power so I turn it off, and then check again obsessively :crazy_face:

1 Like

@HardBlock729 As you seem to have resolved your problem, Joshua, I am closing this topic. If the problem should recur, don’t hesitate to open a new topic with any new information you can provide.