My 48x30 MK2 disconnected in the middle of a job today

Hello, I was wondering if anyone has any ideas as to why my machine disconnected twice today while in the middle of a surfacing job?
Thank You Very much for any advice!


Hello @mlmissel14 welcome to the forum! Good people with sound, friendly advice. So your CNC disconnected twice? First thing first. Has this ever happened before to you?
Have you……

  1. Changed computers?
  2. Ensured your computer didn’t go to sleep?
  3. Have you grounded your dust collection?
  4. Changed usb cables? (That was my issue, a worn usb port in my old MacBook Pro)
  5. We’re trying to multi task on the computer while carving? (Don’t use my computer for anything else when carving)

The key, however, to effective troubleshooting is to do one thing, see how it works and then move onto the next thing. Doing or changing too many things at once will force you to pull your hair out. We don’t want that. :joy::joy:

I would start by making sure your laptop or computer isn’t going to sleep or going into power saving mode. I use a Mac for GSender, so someone who uses windows should be able to chime in here. If I were to guess, that would be my guess.

Please post what you do and the results. Others after you may have the same problem and this thread may save someone some grief too.


I had a similar issue and Sienci labs had the answer for me. I’ll post the reply I got. I hope this helps you too,

I know that this is a bit long winded, however Here is what I reported.

Good afternoon Jason,

I hope all is well in Canada? I finally got my SLB connections completed, :smiling_face_with_tear:shew. As you’ll see in the video, the wire routing is something else. I have a problem that I haven’t been able to resolve. Perhaps you can give me some insight??

After connecting to my computer, all is well. When I home the machine, it disconnects itself. I thought I might need a larger step off, however that doesn’t seem to have an affect.

Any direction would be great and thank you :pray:

This was his response:

Hi David

We have had a couple of reports about this and believe there is a setting in your Firmware EEPROM page that needs to be updated. Can you navigate there and update your $26 from 25 to 250 ? Once you change the number, you can hit tab or enter or click outside of that box, then hit the Apply New Settings button for the changes to take effect.

Here are a couple of other firmware recommendations

Some customers have been experiencing motion issues with the faster default speeds with the SLB, we recommend lowering the speeds to the LongBoard default rates. Please take a look at the recommendations below. To update the firmware, make sure it says IDLE in the visualizer.
Open the firmware tool. Scroll down to the following and input the following numbers into your X, Y, and Z maximum rates.

Then make the following changes to the acceleration settings.

Once you’ve made the changes, click apply new settings.

There currently is a bug in gSender if you have one option enabled in the firmware that prevent the ability to jog the machine using the corner buttons.
Open the firmware and scroll to 23 Homing Direction invert . Disable the A-axis.

Then click Apply New Settings

Close out of the firmware tool. You should now be able to use the corner buttons again.

1 Like