New Machine won’t respond

I got my LongMill 48x30 built today, I downloaded Gsender, powered it on and hooked it up via USB. Gsender says it’s connected but I’m not getting any feedback from the machine. The setup instructions say the machine should do a small jolt or make a chunk sound when the computer engages it, and I should be able to jog it with the arrows on screen. I’ve got nothing. What am I missing? The E-stop is not engaged, I have a red light on the control box, using a MacBook Pro running Gsender downloaded from Sienci website. I also tried doing it in Easel with the same results, Easel says it’s connected, but the machine won’t move or act like it’s connected. I’ve made sure to not run Easel and Gsender at the same time, I know they will conflict with each other. Any ideas?

1 Like

Never mind I figured it out and got it to work (sort of). While swapping out a plethora of known good working usb cables, I finally felt the “jolt” then my motors started making a high pitch squealing sound. I jiggled the connection more and felt the machine jolt again. Putting pressure to one side of the usb connection I got it to connect and stay connected, and successfully jogged the machine with Gsender. But the slightest bump at the usb connection and the machine stops responding (even though Gsender still shows it’s connected). Looks like my controller has a bad USB port.


@GUNSandGUITARS open the controller up. The board on mine came loose in shipping and gave me the same problem. After opening up the controller i found the control board worked its way out quite a bit. Once I pushed it back it place all was well

Welcome to the forum @GUNSandGUITARS! Lots of good folks here Dan, very willing to help. I, too, use a MacBook Pro to run my CNC machine. If you believe the controller board has a bad USB port, just get in touch with Sienci. They will take care of your issue really quick!

In my case, one of my USB ports on my MacBook Pro is “wore out” and quite touchy. I use that one for the thumb drive instead of the machine controller. I really can’t complain as it is a 11 year old machine and has outlived a similar vintage windows laptop I tried to use first. Make sure you are using a good USB cable, preferably a shielded one.

Can not wait to see what you make with your LongMill. Again, welcome!

You’re absolutely correct, that was my issue, thanks for the help!

Hey Jake, thanks for the help! Shipwreck was correct, my board had come loose during shipping. Taking the cover off and pressing it back down fixed the issue. Thanks for the heads up on the MacBook Pro USB ports wearing out. I’m rocking an old 2012 model that just won’t die. But it runs my other cnc lasers just fine, and now that I fixed the controller it runs the LongMill just fine too! Thanks again for the help!


@GUNSandGUITARS you are very welcome! Glad you got it fired up! I have the same vintage MBP and it is a rock solid computer, perfect for running the LongMill. Now go make some dust!

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.