Outline bug in 0.7.4

This may not be new to this release. I don’t recall doing these exact steps in previous versions.

On my numeric keypad,I have a hot key assigned to “return to all zero”.

After I run the outline feature, the key to return to all zero does not work. The GUI go to XY0, then go to Z0 work.

After using the GUI, I can jog and the hot key works again.

Looks like a leftover gremlin. We’ll see what makes sense to do to fix this

1 Like

Any recent report on this outline issue? Otherwise I’ll close this topic

@chrismakesstuff This is still happening in 1.0.6

Here are the steps that I took this morning:

  1. I opened a file (I tried this with 3 files, actually).

  2. I set X0Y0Z0.

  3. I clicked on “outline” in the GUI.

  4. After outline ran, I used the GUI to jog in X, Y and Z.

  5. I clicked on “return to 0” on my keypad.

6 Nothing happened.

  1. In the GUI, I clicked on " go to X0Y0". The mill did return to XY0.

  2. I clicked on “go to Z0”. The Mill did return to Z0

  3. I jogged using the GUI again.

  4. I pressed on “return to 0” on my keypad and the mill did return to all zeroes.

  5. In the console, when I press on “return to 0” on the keypad, it issues the code G0 X0 Y0 Z0.

  6. So, I ran another outline. After it ran, using the GUI, I jogged in X,Y and Z.

  7. Then I entered the code G0 X0 Y0 Z0 into console and hit Enter. Nothing happened.

  8. I repeated steps 7 and 8 and it ran as before.

There was no reason to expect that entering the code in console would produce different results from using the keypad as a keyboard shortcut, but I figured that it was worth testing.

1 Like

Ok I think @KGN and Walid saw this and are working on it but I’ll tag just in case

Hey Grant, Kevin reminded me gSender doesn’t actually have a Go to zero hotkey anymore, just a Go to XY0. Which one are you pressing?

@chrismakesstuff Hi Chris. I guess that I wasn’t clear. :grinning: I have a keyboard shortcut on my wireless number pad that is “go to X0Y0Z0”. I set this up early on in gSender’s development, when the shortcut menu included this process. Even though the shortcut menu no longer includes this option, clearly the updates to gS do not update whatever file it reads for shortcuts, so my shortcut is still available on my keypad. (As you know, the GUI also used to have a button that sent to all zeroes, but it was removed because users were not setting a safe Z and they were dragging their bits across the work piece.)

This command does not work after an outline command. That scenario is set out in steps 1-5 in my previous post.

In step 6, I clicked on the GUI for “go to X0Y0”. That worked. In step 8, I clicked on “go to Z0” in the GUI, that worked.

So, in short, if I want to stick to the GUI 2-step process to go to all zeroes, I can. However, following an outline command, if I want to go to all zeroes in one step, I can’t.

Just to be clear, my shortcut to go to X0Y0Z0 works fine if I don’t do an outline first. Clearly, the outline function does something that removes the ability go to all zeroes in one command, either by shortcut, or by using the console.

This is not a big deal, for me at least. I seldom use the outline feature. It is simply one of the processes that I tried in an attempt to test all possible scenarios. :grinning:

Hi,

The shortcut was removed but your configuration still contains it for some reason - the migration must have failed to remove it for you for some reason when we made those alterations.

The reason you see no movement using your spooky ghost shortcut after running outline is that outline sends a G91 Z-5 movement at the end to go back to the original position - so all movement is incremental. The ghost shortcut just sends “G0 X0Y0Z0” - and an incremental movement of all 0 is not a movement at all.

If you want your go to all zero button to always work in all scenarios, you can make a custom macro that is just “G90 G0X0Y0Z0” and keybind it to the same button your ghost shortcut is on your keypad. I’m also going to make some alterations to the outline tool to return to the original movement modal after outline is complete if it wasn’t G91.

Past that, this isn’t going to be an issue for any other users since they (likely) won’t have the ghost shortcut kicking around.

Kevin

@KGN I love the “spooky ghost shortcut” label. Of course, I am always impressed by tech speak. :grinning:

Tks Kevin