Pause button and other things

Hitting pause button nothing stops, pause button disappears, no restart button just red stop job button. This is a very repeatable issue that I have been trying to figure out for about 4 hours, does it in all files I have tried. Attempted to download diagnostics file and gsender locks up, I have been waiting for around 90min to see if it will complete the download so far.

Running 1.4.7
SLB
Ethernet connection
on windows laptop

About ready to go back to original longboard and 1.2.2. Any help appreciated.

@Mickus Does everything work as it should if you connect using USB?

Grant, I understand that this issue seems comms related. I have tried every connection, 1 ethernet, 2 usb A and 2 usb C. Result is the same. I went as far as testing my connections by connecting to my desktop and transferring files back and forwards without issue. I also connected to the tv and played one of the grand kids games.
I had an issue a few days ago where I was getting gcode errors with known good files that with the help of Peter I was able to trace to a bad cable that came with the slb. Since replacing the cable I have been testing out various function of gsender, jogging at top speed, calibration, surfacing, laser tests all were okay till I decided to test the pause function. It reminds me a lot of the issues I experienced with the 1.1 and on versions were constant loss of connection was a problem until version 1.2.2 was released and everything ran correctly.
I may try using my desktop after church today to see what happens. Though I am really inclined to revert back to the original longboard and 1.2.2 as in terms of effort that is the easier option for me.

@Mickus I’m inclined to believe that this is a SLB issue and not a gSender bug. If you do revert to the original longboard, it would make it easier for Sienci to diagnose the problem if you did not go back to gSender 1.2.2 at the same time. Change out the board, but stay on 1.4.7. Use the same usb cable. Try the same files. If pause, etc works, you will have narrowed down the issue to the slb. Just a thought.

Grant, that is the conclusion I had arrived at also. I plan to try it today or early tomorrow. Will report back.

1 Like

I think I should contact seinci about possible malfunction of new board.

@Mickus If everything works well with the long board, but not with the SLB, I would think that it’s a safe bet that the SLB is bad somehow.

Not sure why but last post should have read.
Installed original board. Pause button working correctly. Think I should contact sienci.

1 Like

@Mickus I figured as much, Michael. :grinning:

A couple things you can try:

  1. What happens when you manually hold in the console (! in console to hold, ~ to unhold)?

  2. Do you have a pause event and is it enabled?

Kevin I was just filling out a tech support request but this works better I think. I am not sure exactly what you are asking in either of your questions. If you can clarify I will go and check.

  1. What happens when you type “!” in the console? Does the firmware properly enter a hold state? Ultimately this is what the pause button does.

image

  1. Do you have a pause event enabled? You can look in Preferences → Program Events and see if the Pause block has code in it. If there is, disable it and try to see if your behaviour is different.
    image

  2. What is the value of your $10 eeprom? You can type $10 in the console to have it report it back or share a screenshot of your firmware tool with the currently set toggles of $10.

Thanks Kevin I will get back to you I have to reinstall the SLB to check.

OK kevin,
Typing “i” gives me a hold after a short delay. I retested the pause function and it works after 8 seconds which I can live with though not sure why it takes so much longer than old board and grbl.
My pause event has the m9 for stop. Removing it makes no difference.
My Eprom 10 is setup exactly as you show.
Seems for some reason I have slow comms?
I am using hp envy laptop
amd 2.3 ghz processor
8gig ram with 7.3 usable
64 bit operating system
windows 11

So you do have a pause event enabled? You need to disable it (not remove the code itself, use the toggle) if you want the program to stop immediately. I’ve explained why in another post but the short is with a pause event, we stop sending gcode but don’t hold until the event runs because otherwise there would be no way to send the pause event itself.

This is probably more noticeable on SLB due to the increased buffer size and is likely a feature we’ll have to revisit to see if it’s worth keeping.

Thanks Kevin what you say makes sense, I will disable and see what happens

Kevin, disabled pause event and pressing the pause button now results in immediate stop of program. Thanks for your help.

@Mickus @KGN And that, gentle readers, is why they pay Kevin the big bucks. :grinning: And why I am not on the Tech Support team.

Since Kevin has resolved your issue, Michael, I’m closing this topic.

1 Like