Problem with unit stopping

I have one of my first problems that I don’t think is user error lol. I’m working on an inlay and was cutting out the plug. The clearance cut went fine but in the middle of the v bit cut the machine
stops. No error code, nothing just stops at 1 minutes 11 seconds in to the cut. I have reloaded the g code several times, restarted the system several times but it always stops in the same place.

Any thoughts?


Problem with cut.crv (1.5 MB)

@MikeH What post processor are you using, Mike? It’s odd that it always stops in the same place. Can you post your gcode for the vbit toolpath?

Does it appear to still be running on gSender when the machine stops?

1 Like

Yes, g sender goes to idle. It says paused, I press the pause button and it changes nothing.

Are the power settings in the laptop set never to sleep? Or some other power saving settings?

It is set to never sleep and the computer is working fine when it stops. It cuts the clearing path with out a problem. Bad timing for this, I have Christmas projects that need to be made.

I’m not sure how to save the g code in a form I can send, I’ve never looked at the g code. Never had to.
My equipment is the Longmill MK2. I use g sender and have never looked at the post processor either. It setup automatically so I never had to look. I’ve never had a problem that required it. I will look Monday to see what it is.

Any help would sure be appreciated

@MikeH The gcode file is the one that you open in gSender to send to the LM. If you are using the correct post processor, it will be a file with the extension .gcode. You create it in VCarve when you save the toolpaths. It is not done automatically. As for the post processor, you select it in VCarve before you save the gcode. It should be either grbl inch or grbl mm.

Yesterday was a long day.

Post processor is Grbl inches and her is the g code for the project. Hope that helps. Today I’m going to do some test on other projects to see if the problem is just this project.

Again thanks for any help.

V-Carve 1_1-V-Carve 1 [Clear 1].gcode (6.3 KB)

@MikeH You are going to hate me, if you don’t already. As I understand it, the clearance code runs fine. It is the cut with the Vbit that acts up. You have attached the gcode for the clearance bit. :grinning:

That figures, I just deleted the gcode for the project. I made a new project with the same parameters and ran it, it ran fine so I’m going to redo the project to see if it will run now.

I’ll let you know in about 20 min if it worked.

1 Like

It did the same thing. This thing is driving me nuts.

Here is the 30 v bit path.
V-Carve 1 [Clear 1]_2-V-Carve 1.gcode (198.7 KB)

When I do a test run in gsender the test stops in the same place also. The bottom of the first c in Rebecca.'s Not sure what would cause a bad gcode. I have redone the tool path and generated a new tool path several times with the same results.

I didn’t want to start over because I already have the pocket cut for this project but maybe I’ll have to. As I said before I ran a new project from a new file and the plug cut fine. I guess I don’t know enough about how the inner workings of how tool paths and gcodes work but could there be a flaw in the project of some kind? There has to be one somewhere…

@MikeH When you run the visualizer in Vcarve, does it complete OK?

It runs it fine in vcarve. In gsender it stops every time.

@MikeH I just ran it in ncviewer and it completed. A bit later this afternoon, I’ll run it on my LM, in air.

When it stops for you, are you actually carving, or are you running it in air?

It stops in both. I am running some tests with the original file and a new file, the new file runs in the simulation so I’m going to cut the new file and I’ll let you know what happens.

Thanks for taking time with me on this.

1 Like

Well, I took the file and copied it to a new vcarve window and it still did not cut so I made a whole new file and it cut fine so there is something about that file that is corrupt. That’s above my pay grade. Fortunately it was not a big project so I’ll start over.

I am curious about what in the file caused the problem if there is any insight to that.

Thanks again for the help.

@MikeH I may have found the “what”, but not they “why”.

Just to confirm my suspicion, can you please post the gcode file for the successful file - just the vbit part. If I can compare it to the bad one, I may be able to see what went wrong. Why it went wrong will likely stay a mystery.

top plug_2-top plug.gcode (254.6 KB)