Problems with g sender and the XY datum

I’m having some kind of a weird, bizarre experience and I’ve never seen with g sender before

Basically I run the home button and everything looks like it’s fine. See the picture

However, I go into the surfacing tool put in the specs for my 48x30 see the picture

Then I click generate g-code and then turns for it over to the visualizer

If you look at where the X and y0 are right now it’s in the upper left but I don’t know why it’s doing that

Took me a while to figure this out that this is what it was doing. Obviously it’s going to plummet itself into the negative X and Y. For some reason I’m not sure

But the one thing that I have started to notice that if I hit the start button and then stop button and then start button and stop button, the Zed settings seem to get lost

Basically it’s if I stop the program and then start it because of an error. It plunges my spindle right into the table. See the picture

Is this a bug or a settings problem?

@Menglor - Stephen, looking at the visualizer picture down at the bottom middle of the screen. It is showing the dimensions that you specified. It’s showing X at 816 mm and Y at 1200 mm. Shouldn’t that be reversed? I think Length is Y and Width is X. I don’t know if that will correct what you’re showing or not but start there. Keep us posted please.

@Menglor - Stephen, stop the presses! I see the problem. You do need to reverse the dimensions first. Then look at the Start Position. It’s set for upper left back corner. Move it to lower left front corner.

1 Like

Awesome, thanks

Where do you change the setting? Never seen it before

In the surfacing window. Length should be 816 and Width should be 1200. Then Just below the Spindle M3 or M4 and just above the Generate G-code button is a box where you select clearing pattern. Either spiral or back and forth. There are four circles at each corner of that box representing the four corners of your cnc. Click on the lower left circle and then generate your g-code.

1 Like

@Menglor - Also on the Start /Stop issue whenever you hit the Stop button gSender does a soft reset. That will most likely be the cause of losing your Z. Use the Pause and Resume buttons and that should keep all of your axes.

1 Like

Wow. Much appreciated.

Not sure how I missed those quadrant buttons

It’s all working awesomely

Your help was invaluable


So a request to the developers to avoid future issues …
Get rid of the the Length /Width stuff .

Change the label

“Dimensions (XY)”


@Menglor @Heyward43 Heyward to the rescue - again.

As H as you all fixed up, Stephen, I am closing this thread. As always, we invite anyone with a similar issue to open a new thread so that your specific issue can be addressed.

1 Like