Problems with GSender or my Longmill

Hello

I am going to preface this, with a I dont know where the problem is.

  • I am unable to currently reproduce the problem with repeatable steps.

  • I am however able to reproduce the problem after about 30 minutes of following the bellow steps.

Case :

  • I currently have a GCODE file that surfaces a piece of board that is 14x16" in size and it removes 1mm off the Z axis.

I and currently trying to make a segmented board, so I am using the surfacing program to clean up the glue on the wood.

I follow the SAME STEPS for each board:

  • Open Gsender, and load my Surfacing program.
  • I ZERO my X and Y to the center of the planned work piece

1 - I move the Head away from the work area
2 - Secure 8" x 8" by 3/4 inch to my work table.
3 - I probe for the Z with Gsender.
4 - I clear away the probe and Return my X and Y to Zero,
5 - I start my Spindle and start the head rotation.
6 - I click on the START program
7 - I allow the program to run for 5-10 minutes while it surfaces the board.
8 - I click on the STOP Program once I have successful covered all of the wood I want surfaced.
9 - I move the head out of the way.

I then either

  • flip the board over, and do the exact same steps on the other side
    or
  • replace the board with the next board needed to be surfaced.

I complete this operation about 4-6 times, and then my Longmill goes into Stupid mode.

  • Every click of the mouse takes 4-10 seconds to respond to the click.
  • if I close Gsender and re-start it, and connect. I get a Connected popup, but the message in Gsender constantly shows Disconnected.

I have attached 2 video’s to show the behavior once its locked me out.

  • note reaction from clicking on mouse to when the head actually moves.

has anyone else seen this behavior?

No amount of closing the application and restarting it solves the porblem.

I have to Reboot the PC to get it to work again.

once I reboot, it will go “for a while” then behave this way again.
the buttons on the Gsender are un-responsive, for 5 - 10 seconds.

@Menglor I’ve not had this issue, Stephen, but have you tried the same project in UGS? If so, what happens.

Do you have all the power saving settings turned off in Windows, especially the one for USB ports/

Just for my information, what do you mean when you say that you " start the head rotation"?

I don’t have Ugs setup anymore.

I will need to dig it out again

As for starting it.

I have my spindle wired for 220v

I control it outside of the software.

So I power up the 220v wait for a few seconds and hit the start button on the driver, wait for it to spin up and then run the program from gsender

@Menglor Tks. I don’t know if UGS will solve your problem, but at least if the problem persists, you will know to look for another cause. If things run properly in UGS, you can file a bug report on gsender.

agreed, however because I cant reproduce on demand, its dificult to rule out what I am seeing.

I have seen it 2-3 times working on what I was doing , however that task is complete. so I am going to try and see if I can reproduce it. but Not going to hold my breath

@Menglor Intermittent issues like these are incredibly frustrating. I hope that you can nail down the problem.

So I’m at this point ready to give an update

I got my ugs up and running and everything has been working fine except for two instances or the thing buggered up

The odd part is that it’s the exact same problem as gender I reached out to Sienci, and I was instructed to remove the power management off of my USB controllers

I’ve been playing with Windows for 30 plus years this is the first time I’ve seen power management in the device manager

I’m on day three of running with ugs and gender

No issues so far except for one burp today

@Menglor Glad to hear it, Stephen. That’s what I meant in my comment of last week. Sorry that I wasn’t clearer. Power Management has been around in windows for a long time, but generally caused no grief. Then usb-powered cnc controllers came along and broke the peace.

I mean I know exactly what power management is and where it found.

I just never seen a power management tab on the USB driver in device manager

My plan is to move forward to try to with the raspberry Pi

The lockups are more infrequent now but I still want to rule it out

And you’re right power management in Windows is a joke. So if switching to the raspberry fixes my issue with the gender or ugs or whatever comes next I’m good with that

It’s probably overkill but this is my next project

Touch screen, raspberry Pi and a long mil

2 Likes