Raspberry Pi Stuck on Splash Screen

I just loaded gsender (gSender-1.1.2-armv7l.AppImage) on a Raspberry Pi, 3b. It throws up the splash screen and just sits there.

Looking at it, it looks like it is just throwing the splash screen gif up and it just stays there like I opened and image and not an app.

I did see an entry for a windows user with a similar issue, but nothing on a Pi.

Any suggestions would be appreciated.

I am having the same issues. I have even tried to load the Pi OS 64 bit and it does not work either. I went back to an older version and it does not work. I am getting the same thing with just the splash screen.

I did have an older version working on my Pi, but had not used it for a long time because I didn’t have a display. When I got my new display, I re-imaged the Pi and now it does not work. I will have to see if I still have the version I had working.

1 Like

It looks like it broke when they went to 1.1. I have loaded multiple versions pre 1.1 and they seem to load just fine. I guess since my PC was on 1.06 I should be fine with my Pi on the same version, but I am hoping to take advantage of some of the new functionality especially for the laser.

okay everyone I have tried everything i can think of and I still cannot get gSender to work on my Pi4. I have tried with a 32 bit and a 64 bit OS. I have done all updates and upgrades. I have tried older versions of gsender to no avail. What else does anyone have?

Has anyone been able to get Sienci lab to reply to the issue?

Well, there might not be an issue. They’re having a time of it getting gSender features to all work at the same time on a PC let alone all the other variations. :smiley:

I really like the program but may have to switch back to UGS for now. Hope they get it worked out. It is a great program. Also would like to know if any one has a macro go-by. I do a lot of repeated cuts in the same starting point and would love to be able to automate some of the things I do.

Our pi build process incorrectly built the serialport bindings for 64 bit instead of 32 bit. We’ll look at getting a new build out for Pi with the correct bindings.

Kevin

2 Likes

Cool, thanks. Looking forward to having this work on the PI. Even on the older code, I am having issues with it fitting on the screen, and for some reason I can’t change resoution

Just noticed there is a new release out for the Pi. Downloaded it and it works. Just wish I could get my screen to resize, as it is not useable for me right now.