Runaway Jogging issues with UGS Platform

This has been an ongoing issue since getting started with my Long Mill. I have learned one can set the distance of the jog when jogging, however on several occasions when setting up my zero, with short increments, like .05" several mouse clicks the machine goes to it’s limits, alarm goes off, I hit the kill button, try again. Am I missing a setting? Doing something wrong? Drives me nuts when this happens.

Is this a UGS issue? How can I stop this. if the left mouse button is held down too long it’s off to the races.

I have kinda learned how to make it behave but my wife is starting out with her designs and it’s alarm city when it hits the end of an axis. Can’t be too good for the machine to physically hit the end of the trail…

@Bill I’m sorry if you have posted in another thread, Bill, but what version of UGS are you running?

1 Like

Not sure if I posted in the correct category Thread, didn’t seem to be an equipment issue, but anyway it’s UGS Dec 02, 2020, should I move to equipment support?

Should have read 12/12/2020

This was happening to me when I would hold my X or Y jog key down for longer than about 3 seconds. I had my feed rate set to 10,000 in the jog window. I have since dropped it to 2,000 and I don’t have this issue on the x or y. It stops now when I let go of the mouse button.

It does still happen on the XY combo movement arrow key, though. Perhaps dropping the feed rate to 1,000 or 100 makes more sense.

Don’t know if that is specifically the issue or not. I have the most current 12/2020 version of UGS.

1 Like

Thanks @stevendq , will give that a try, as I said earlier i have learned how to live with this, kinda know from experience what “Is too much” and just live with it, just seems a little antiquated to me.

1 Like

@stevendq That was it, at 100 it is smooth as silk, maybe that is worthy of setup info!

So very thankful!!!

1 Like

@Bill @stevendq FWIW, my speed is set to 3000 and my step is set to 1. I don’t have any problems.


@Bill glad it worked.

@gwilki 1,000 bugs me…feels slow…

1 Like

@stevendq Agreed. I’m at 3000. Max for x and y is 4000. Max for Z is 3000. So, I just chose 3000.


Makes me wonder why I missed this? thanks to all that helped me. There are so many subjective issues when setting this thing up, Tight but not too tight etc. I have been carving away but having small irritants, maybe just me.

I tried different settings, even at 1000 it goes nuts, travels to the limits, I’m fine with 100 but makes me wonder about differences, environmental? tensions etc at set up? Makes me question my set up.

Hey Bill :wave: I might add here that it might have more to do with how UGS runs on different devices

Seems that the trick is to intercept the machine mid-jog to stop when you’re expecting it to, but perhaps on slower machines that command is getting more bogged down then on others? Or if you’re running more processes in the background?

Hard to say definitively since we’d have to have a whole array of devices in our office to test on

Hi @chrismakesstuff , Dell laptop, i5, 16gb ram, nothing else running with UGS Platform, I only use this Laptop with the CNC. I’m old, 100 doesn’t bother me, works fine.

@Bill There is one thing that you can try, Bill, that may not help, but certainly will not hurt. Go into the power settings in windows and make sure that all the power saving options are turned off, especially the somewhat hidden one that controls power to the USB ports. That one is turned on by default in windows 10. Freaky power can cause UGS and grbl to act up, and this may help.